summaryrefslogtreecommitdiff
path: root/dev-python/fido2/fido2-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-02 05:22:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-02 05:22:02 +0100
commitf20a854a6189579b2cc296900c479d9b6b5b595e (patch)
tree310fb68782e96ae228c8ffe97ae3b2859a7e4a17 /dev-python/fido2/fido2-1.1.0.ebuild
parentb7e514e2dc987a8b3e10ea8ea3d6e1d197eeb355 (diff)
gentoo auto-resync : 02:05:2023 - 05:22:02
Diffstat (limited to 'dev-python/fido2/fido2-1.1.0.ebuild')
-rw-r--r--dev-python/fido2/fido2-1.1.0.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/fido2/fido2-1.1.0.ebuild b/dev-python/fido2/fido2-1.1.0.ebuild
deleted file mode 100644
index bf17632b1a20..000000000000
--- a/dev-python/fido2/fido2-1.1.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=poetry
-
-inherit distutils-r1
-
-DESCRIPTION="Python based FIDO 2.0 library"
-HOMEPAGE="
- https://github.com/Yubico/python-fido2/
- https://pypi.org/project/fido2/
-"
-SRC_URI="
- https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz
-"
-
-LICENSE="Apache-2.0 BSD-2 MIT MPL-2.0"
-SLOT="0/1.0" # Bumped every time a backwards-incompatible version is released
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
-IUSE="examples"
-
-RDEPEND="
- <dev-python/cryptography-40[${PYTHON_USEDEP}]
- <dev-python/pyscard-3[${PYTHON_USEDEP}]
- examples? (
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- docinto examples
- dodoc -r "${S}"/examples/.
- docompress -x "/usr/share/doc/${PF}/examples"
- fi
-}