summaryrefslogtreecommitdiff
path: root/dev-python/fido2/fido2-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-19 19:01:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-19 19:01:00 +0000
commit60945053af0588a6219a4a6867aace9e7b47faeb (patch)
tree01b47053786c26a3e31ca562d46dfd252fe22cd7 /dev-python/fido2/fido2-1.0.0.ebuild
parent26f79803004cb53e92cf2f0e889de89979385aa9 (diff)
gentoo auto-resync : 19:11:2022 - 19:01:00
Diffstat (limited to 'dev-python/fido2/fido2-1.0.0.ebuild')
-rw-r--r--dev-python/fido2/fido2-1.0.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/fido2/fido2-1.0.0.ebuild b/dev-python/fido2/fido2-1.0.0.ebuild
deleted file mode 100644
index 20e8481f1821..000000000000
--- a/dev-python/fido2/fido2-1.0.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_PEP517=poetry
-
-inherit distutils-r1
-
-DESCRIPTION="Python based FIDO 2.0 library"
-HOMEPAGE="https://github.com/Yubico/python-fido2"
-SRC_URI="https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD-2 MIT MPL-2.0"
-SLOT="0/1.0" # Bumped every time a backwards-incompatible version is released
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
-IUSE="examples"
-
-RDEPEND="<dev-python/cryptography-40[${PYTHON_USEDEP}]
- <dev-python/pyscard-3[${PYTHON_USEDEP}]
- examples? (
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- docinto examples
- dodoc -r "${S}"/examples/.
- docompress -x "/usr/share/doc/${PF}/examples"
- fi
-}