summaryrefslogtreecommitdiff
path: root/dev-python/ffmpeg-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/ffmpeg-python
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/ffmpeg-python')
-rw-r--r--dev-python/ffmpeg-python/Manifest5
-rw-r--r--dev-python/ffmpeg-python/ffmpeg-python-0.2.0.ebuild38
-rw-r--r--dev-python/ffmpeg-python/files/ffmpeg-python-0.2.0-_run.py-collections.patch12
-rw-r--r--dev-python/ffmpeg-python/files/ffmpeg-python-0.2.0-setup.py-pytest-runner.patch11
-rw-r--r--dev-python/ffmpeg-python/metadata.xml13
5 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/ffmpeg-python/Manifest b/dev-python/ffmpeg-python/Manifest
new file mode 100644
index 000000000000..24654312e5c6
--- /dev/null
+++ b/dev-python/ffmpeg-python/Manifest
@@ -0,0 +1,5 @@
+AUX ffmpeg-python-0.2.0-_run.py-collections.patch 507 BLAKE2B 6e503e627656775c4cc665ff68adf4afd8ed36131b2d55cdd00d420aefbb69d1585ddc8ec6513b64ddcea1a20d0d522d9d9d0d885c1d03e7d11de3741543782c SHA512 571087d23eec2880de37cec5799f967a2cb498b56e1109e086ead82cf65f8fac94cbc9c63953954f7ab3b59970285ecc18f5c446fc930a0c09ac8552251d47ec
+AUX ffmpeg-python-0.2.0-setup.py-pytest-runner.patch 366 BLAKE2B 874898215b2102406fa11ab4e2289671dc03a8b40a8831aa6958048b94c64a5cd1cd34d326539144ebe549046cb0df074e6ffb4b37a72aaa44d94c0bc161cfb6 SHA512 627bfc39b3f0feef02306d73d8dc113673483e0e1aa5182cada9d12195413d7638b94071a76b546092061d6916d45575a42aa5d949c8bd9df737c34b1b62ea71
+DIST ffmpeg-python-0.2.0.tar.gz 3267771 BLAKE2B 8bca4a24434b6c7a542e3c178cb7bf1e5650f9763636d5378f9652cdd07ef19b0e96007d6bb71fdf1664efb6e33d597844c7d6a44dc8dcb1c083e21f53649469 SHA512 933ed958d61536bbbc0e0b08e19521c4b1f7df1cfe97de0b3d149a2748c5bd74915a3134861e8ecb1f92d5860315228b76aefcd087fcf07e188a56c651f5e301
+EBUILD ffmpeg-python-0.2.0.ebuild 918 BLAKE2B 839fe64da380e4fa8c5d4fd1e9c940920858c3935d7a7a70bf35ff879cd094e363de4198e8ac60991b348924d2091fce43c025a2224835d9d924b23cb97241e3 SHA512 df450ca269d477a22b4a0bbdab9a126ddbddfb9a4544f5940244ee5de96892f1e5686ae35b7101c3fac658349be0eff8ad2e0bfebbf1a9d15743c40debb17f80
+MISC metadata.xml 417 BLAKE2B 86f8cba73359487932c4515f4369fc89f0c162693977c8b7ab49c7f3eb1fb3bfb713cb4e2c25b41674891610ed0de6dba6616289b951cb39abe5645a475f4b39 SHA512 27e9d1f757e395fe23660531924c5ea4faa41c782b4ab240ba616aea2bf439cf93b2d21166ff693a9c0055637160bd94c31b8e58dd84c662b2d1a3bee2503663
diff --git a/dev-python/ffmpeg-python/ffmpeg-python-0.2.0.ebuild b/dev-python/ffmpeg-python/ffmpeg-python-0.2.0.ebuild
new file mode 100644
index 000000000000..4ee086b79602
--- /dev/null
+++ b/dev-python/ffmpeg-python/ffmpeg-python-0.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for FFmpeg with complex filtering support"
+HOMEPAGE="https://github.com/kkroening/ffmpeg-python"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kkroening/${PN}.git"
+else
+ SRC_URI="https://github.com/kkroening/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ media-video/ffmpeg
+"
+BDEPEND="test? ( dev-python/pytest-mock[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-_run.py-collections.patch
+ "${FILESDIR}"/${P}-setup.py-pytest-runner.patch
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/src
diff --git a/dev-python/ffmpeg-python/files/ffmpeg-python-0.2.0-_run.py-collections.patch b/dev-python/ffmpeg-python/files/ffmpeg-python-0.2.0-_run.py-collections.patch
new file mode 100644
index 000000000000..6231ba17b86e
--- /dev/null
+++ b/dev-python/ffmpeg-python/files/ffmpeg-python-0.2.0-_run.py-collections.patch
@@ -0,0 +1,12 @@
+index afc504d..bf43c06 100644
+--- a/ffmpeg/_run.py
++++ b/ffmpeg/_run.py
+@@ -137,7 +137,7 @@ def _get_output_args(node, stream_name_map):
+ if 'video_size' in kwargs:
+ video_size = kwargs.pop('video_size')
+ if not isinstance(video_size, basestring) and isinstance(
+- video_size, collections.Iterable
++ video_size, collections.abc.Iterable
+ ):
+ video_size = '{}x{}'.format(video_size[0], video_size[1])
+ args += ['-video_size', video_size]
diff --git a/dev-python/ffmpeg-python/files/ffmpeg-python-0.2.0-setup.py-pytest-runner.patch b/dev-python/ffmpeg-python/files/ffmpeg-python-0.2.0-setup.py-pytest-runner.patch
new file mode 100644
index 000000000000..67fbb2308a37
--- /dev/null
+++ b/dev-python/ffmpeg-python/files/ffmpeg-python-0.2.0-setup.py-pytest-runner.patch
@@ -0,0 +1,11 @@
+index 0282c67..2011d2c 100644
+--- a/setup.py
++++ b/setup.py
+@@ -60,7 +60,6 @@ keywords = misc_keywords + file_formats
+ setup(
+ name='ffmpeg-python',
+ packages=['ffmpeg'],
+- setup_requires=['pytest-runner'],
+ tests_require=['pytest', 'pytest-mock'],
+ version=version,
+ description='Python bindings for FFmpeg - with complex filtering support',
diff --git a/dev-python/ffmpeg-python/metadata.xml b/dev-python/ffmpeg-python/metadata.xml
new file mode 100644
index 000000000000..b908e7d7cbe1
--- /dev/null
+++ b/dev-python/ffmpeg-python/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/kkroening/ffmpeg-python/issues/</bugs-to>
+ <remote-id type="github">kkroening/ffmpeg-python</remote-id>
+ </upstream>
+</pkgmetadata>