summaryrefslogtreecommitdiff
path: root/dev-python/fcl/fcl-0.0.12-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
commit7c59acba5699c9c58090a7a738669669a7307023 (patch)
treed51d27d020895a6b7a3298d9d1b9846c1fcb59a0 /dev-python/fcl/fcl-0.0.12-r1.ebuild
parente2db47eaae00ec33f8971db44b68645c5d3b9590 (diff)
gentoo resync : 21.08.2021
Diffstat (limited to 'dev-python/fcl/fcl-0.0.12-r1.ebuild')
-rw-r--r--dev-python/fcl/fcl-0.0.12-r1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/fcl/fcl-0.0.12-r1.ebuild b/dev-python/fcl/fcl-0.0.12-r1.ebuild
deleted file mode 100644
index 5089f5485f46..000000000000
--- a/dev-python/fcl/fcl-0.0.12-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-MY_PN="python-fcl"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python bindings for the Flexible Collision Library"
-HOMEPAGE="https://github.com/BerkeleyAutomation/python-fcl https://pypi.org/project/python-fcl/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-LICENSE="BSD"
-
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- ~sci-libs/fcl-0.5.0
- sci-libs/octomap
-"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=( "${FILESDIR}"/${P}-fix-compiling-on-lld.patch )
-
-distutils_enable_tests unittest
-
-python_test() {
- "${EPYTHON}" test/test_fcl.py -v || die "tests failed with ${EPYTHON}"
-}