summaryrefslogtreecommitdiff
path: root/dev-python/fastparquet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/fastparquet
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/fastparquet')
-rw-r--r--dev-python/fastparquet/Manifest5
-rw-r--r--dev-python/fastparquet/fastparquet-0.1.0.ebuild30
-rw-r--r--dev-python/fastparquet/fastparquet-0.1.1.ebuild32
-rw-r--r--dev-python/fastparquet/metadata.xml24
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/fastparquet/Manifest b/dev-python/fastparquet/Manifest
new file mode 100644
index 000000000000..5ed53f3904e5
--- /dev/null
+++ b/dev-python/fastparquet/Manifest
@@ -0,0 +1,5 @@
+DIST fastparquet-0.1.0.tar.gz 118108 SHA256 dad60f61596b0118b50c727d8abd10115ec5e172ca5cb14211a3d6dfe1075c6b SHA512 9aa61f998cd95e4242635ef729c29fa5c66834bdd501fe7d104317a767c5eebc6a1d1aecbd669a39c855f5f2d1650af153b77f12c0120e6e5d13cb8f78e4cba0 WHIRLPOOL c4bc25df8ca0964f6df19840fd7f8c6aab4a6beb2ef8a3d714291121e73a15d3e005cf4534832782eba64a30ba29c63b92d6862a06c7e1db50910d695bbe8a0d
+DIST fastparquet-0.1.1.tar.gz 119573 SHA256 189105b53f56b5ed4d9077a0b22de0055b79917ae9a083dfb7abe9453d754d28 SHA512 f8f052202ca095596870e6a10e2ab05e3c55289cd0ef3dab0502dff26052c9970f65f6b826d4d073c6c221827f6b18ddc83c47c04e84e08491f5237358f5860a WHIRLPOOL 4c9d7b7523da38f2b8230cbddfe70a6ffec69653858dae1ede5776fa033775420dd9afb31876d2c50df595f43f05f7c8a1698507bb9aaff6e3d3e1b23f83cc12
+EBUILD fastparquet-0.1.0.ebuild 765 SHA256 3ff957371af293acb022b6b05901d6535ed6fb23f68e6631ac7abb0a5cfa31b8 SHA512 aa69b6e9aafd5512d399e7840e2258aefaabddf84cebd5dc7c79db340fb27d956feaec7f3447d13ce70ac9e07d051c5c5eeea1b32a5f0ed488f94ffba5c24c49 WHIRLPOOL 753bb26a3a139918edc0162197443c777b90e5b5df6dedf59ff296c5f23b51304ca9a0731df3705ec6a15c29e9f8fe678120ef7bb14b1362aca598ba52e474a0
+EBUILD fastparquet-0.1.1.ebuild 899 SHA256 53424349119698877b5292e7f948fca8db6fca5d306d82951498cc6237f6b806 SHA512 dc977589378234cf19897bb18483eb4676df014e9dc3c4dda1bf70d7998771f3b5da33c25559cec6eb14f1e3f9b587bf9a0c8fee5ab1509cbfbf5c0265c19b6b WHIRLPOOL 9623333a5d6302e1133299e665eb379b2bc4cbbb28ff18b3401cc47f7fbf2e954647060b12184e305dd01435190df31f7d6e99738a6058f2e813b5a3854b14c9
+MISC metadata.xml 961 SHA256 c738d31ceab32e9f34d642458cf59a8a1b76ccfc3c7b1e8cce8acd9e324937a7 SHA512 2634acb33c585b036fd09df504e7d2d885b287e1b30585233fa7f2d3f7dd7e8206e20adf7061623fb2e8ecb45e714290966c8ed4a27baac56c7909b116eb49be WHIRLPOOL 0d638ce923bd7607f4d01eb932cabe6ff5f0017bc4a6585f5ebd76a576f1eead6ab307fbbe5055284ae40b075fca78df6dbc99f1cdcf9507f403bec493efec23
diff --git a/dev-python/fastparquet/fastparquet-0.1.0.ebuild b/dev-python/fastparquet/fastparquet-0.1.0.ebuild
new file mode 100644
index 000000000000..0f06496d4b59
--- /dev/null
+++ b/dev-python/fastparquet/fastparquet-0.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the parquet columnar file format"
+HOMEPAGE="https://github.com/dask/fastparquet"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/numba[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/snappy[${PYTHON_USEDEP}]
+ dev-python/thriftpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/fastparquet/fastparquet-0.1.1.ebuild b/dev-python/fastparquet/fastparquet-0.1.1.ebuild
new file mode 100644
index 000000000000..01c8d3c54fbb
--- /dev/null
+++ b/dev-python/fastparquet/fastparquet-0.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the parquet columnar file format"
+HOMEPAGE="https://github.com/dask/fastparquet"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="brotli lzo +snappy"
+
+RDEPEND="
+ dev-python/numba[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/thriftpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ brotli? ( app-arch/brotli[python,${PYTHON_USEDEP}] )
+ lzo? ( dev-python/python-lzo[${PYTHON_USEDEP}] )
+ snappy? ( dev-python/snappy[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/fastparquet/metadata.xml b/dev-python/fastparquet/metadata.xml
new file mode 100644
index 000000000000..0866e1d45e83
--- /dev/null
+++ b/dev-python/fastparquet/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ fastparquet is a python implementation of the parquet format,
+ aiming integrate into python-based big data work-flows. Not all
+ parts of the parquet-format have been implemented yet or tested
+ e.g. see the Todos linked below. With that said, fastparquet is
+ capable of reading all the data files from the
+ parquet-compatability project.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">fastparquet</remote-id>
+ <remote-id type="github">dask/fastparquet</remote-id>
+ </upstream>
+ <use>
+ <flag name="brotli">Enable support for brotli compression</flag>
+ <flag name="snappy">Enable support for snappy compression</flag>
+ </use>
+</pkgmetadata>