summaryrefslogtreecommitdiff
path: root/dev-python/fastparquet/fastparquet-0.1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
commitcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (patch)
tree047fc92023c520d07f13ec5ac96e094d1b312a7a /dev-python/fastparquet/fastparquet-0.1.5.ebuild
parent7b9f15840068dfaeea5684f8a1af1fe460dfa14c (diff)
gentoo resync : 09.06.2018
Diffstat (limited to 'dev-python/fastparquet/fastparquet-0.1.5.ebuild')
-rw-r--r--dev-python/fastparquet/fastparquet-0.1.5.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/fastparquet/fastparquet-0.1.5.ebuild b/dev-python/fastparquet/fastparquet-0.1.5.ebuild
new file mode 100644
index 000000000000..dbd31aefa218
--- /dev/null
+++ b/dev-python/fastparquet/fastparquet-0.1.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the parquet columnar file format"
+HOMEPAGE="https://github.com/dask/fastparquet"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux ~x86-linux"
+IUSE="brotli lz4 lzo +snappy zstd"
+
+RDEPEND="
+ dev-python/numba[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/thrift[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ brotli? ( app-arch/brotli[python,${PYTHON_USEDEP}] )
+ lzo? ( dev-python/python-lzo[${PYTHON_USEDEP}] )
+ lz4? ( dev-python/lz4[${PYTHON_USEDEP}] )
+ snappy? ( dev-python/snappy[${PYTHON_USEDEP}] )
+ zstd? ( dev-python/zstandard[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ # this causes setuptool's sandbox violations, Portage should have
+ # taken care of this, so disable it
+ sed -i -e 's/setup_requires/disabled_setup_requires/' setup.py || die
+
+ distutils-r1_src_prepare
+}