summaryrefslogtreecommitdiff
path: root/dev-python/fastparquet/fastparquet-0.1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/fastparquet/fastparquet-0.1.5.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/fastparquet/fastparquet-0.1.5.ebuild')
-rw-r--r--dev-python/fastparquet/fastparquet-0.1.5.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/fastparquet/fastparquet-0.1.5.ebuild b/dev-python/fastparquet/fastparquet-0.1.5.ebuild
deleted file mode 100644
index dbd31aefa218..000000000000
--- a/dev-python/fastparquet/fastparquet-0.1.5.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python implementation of the parquet columnar file format"
-HOMEPAGE="https://github.com/dask/fastparquet"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~amd64-linux ~x86-linux"
-IUSE="brotli lz4 lzo +snappy zstd"
-
-RDEPEND="
- dev-python/numba[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/thrift[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- brotli? ( app-arch/brotli[python,${PYTHON_USEDEP}] )
- lzo? ( dev-python/python-lzo[${PYTHON_USEDEP}] )
- lz4? ( dev-python/lz4[${PYTHON_USEDEP}] )
- snappy? ( dev-python/snappy[${PYTHON_USEDEP}] )
- zstd? ( dev-python/zstandard[${PYTHON_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
-"
-
-src_prepare() {
- # this causes setuptool's sandbox violations, Portage should have
- # taken care of this, so disable it
- sed -i -e 's/setup_requires/disabled_setup_requires/' setup.py || die
-
- distutils-r1_src_prepare
-}