summaryrefslogtreecommitdiff
path: root/dev-python/fastimport
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/fastimport
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/fastimport')
-rw-r--r--dev-python/fastimport/Manifest7
-rw-r--r--dev-python/fastimport/fastimport-0.9.11.ebuild21
-rw-r--r--dev-python/fastimport/fastimport-0.9.8-r1.ebuild26
-rw-r--r--dev-python/fastimport/fastimport-0.9.9.ebuild21
-rw-r--r--dev-python/fastimport/metadata.xml14
5 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/fastimport/Manifest b/dev-python/fastimport/Manifest
new file mode 100644
index 000000000000..11d986ddbf74
--- /dev/null
+++ b/dev-python/fastimport/Manifest
@@ -0,0 +1,7 @@
+DIST fastimport-0.9.11.tar.gz 41764 BLAKE2B afb82878ea1996894ff71fe99edc5ca26d45f98eedf7a8a6e85af45949e1e81c2112de9fc2c026438306a8a0e89c484063954ba7d2ff9a80c6b71ab40174f8d4 SHA512 e1b7e4897542ef6f33af51e1018340a6807688e44424e4e7e482b3347264d58d4290678cc2cfa230af500a53cabdcf35c9e7b03c8ff0f1ec3e6e0a9e869a1455
+DIST fastimport-0.9.8.tar.gz 39512 BLAKE2B 484ba865e749cca33df73417285e51a9117e7c905ab2922588d6eef9a64ea6b3d72de285a2affbe7d4a770ead9ece30f6242777087af1c469d59c8f2a4e1b008 SHA512 5d195b641cf6138fdbc6c75781a4a6d3699e3ada9743bbe4c4264879b2da2f8a2e995e7cc3955a5241e9c7a7f24f8114474a0a30907f86e2e335e2be4669f588
+DIST fastimport-0.9.9.tar.gz 41690 BLAKE2B c07774916d42a6ad98fea3fa8185bd6fd4e2b908d7eb90ec28a2d7dbe5fd806a97075ba0bb5e6dc4fa3330c9e1e46db125daa11062dba52cc9ebc4486c0fff12 SHA512 15005da2056e0d489f9317138833131ae2067cc5b4acd1ab8e82142c6a71e7cc600c3d5a2cbfc151ca253ba3f6aa5f0328fb45dfa912987bb28d4762248298b8
+EBUILD fastimport-0.9.11.ebuild 660 BLAKE2B 7f3d729234f0f89f0624e850f47980675e9dea498c5debd92fee7e5753970598846bd0be3f21a912fce3ac615b16a0d72859a223a8ea70c8ebc99e44c0aff943 SHA512 efdc0ac66850bb36f6685771c5fd39f656a1236505e9ec8fd6e4db5ed6a002f0b730559ac77b53597abb733995b20908283893ada4e47f34d631c94b5bf0637b
+EBUILD fastimport-0.9.8-r1.ebuild 765 BLAKE2B fd9cc0c7818f32052e6079b085dfed2d07aca3e9826dadbe223437538f72d5ae871f99fabe3f01a4f18535ecb0025f91d3bb47ecf585f901de0848d9c00f5e65 SHA512 a690327a037774b8516c679174e6107a1c5116f5d976971e1b67e0d3db01268cfe8e7d0c274d767f23c3203f1e3f4604817627dad1e08d8abd1989d3f582e675
+EBUILD fastimport-0.9.9.ebuild 660 BLAKE2B 7f3d729234f0f89f0624e850f47980675e9dea498c5debd92fee7e5753970598846bd0be3f21a912fce3ac615b16a0d72859a223a8ea70c8ebc99e44c0aff943 SHA512 efdc0ac66850bb36f6685771c5fd39f656a1236505e9ec8fd6e4db5ed6a002f0b730559ac77b53597abb733995b20908283893ada4e47f34d631c94b5bf0637b
+MISC metadata.xml 509 BLAKE2B 23407a89645a4f2fbc0954f2f02eb60c74e8aaf2c7385d3d8c098e64fbf949b66f262378de964c5fae6d84db4e6e04d4000438c8cbf4d44fc629d74e2f524b42 SHA512 2242fe2ba9731aee3face6de5e7fe146ecab037b24825a7fd5ed26bbfcf4136ab50791ccaaea4bcac5a23711fdbcac30e2181a39c8d0a3d33cd7acfe56ea2f56
diff --git a/dev-python/fastimport/fastimport-0.9.11.ebuild b/dev-python/fastimport/fastimport-0.9.11.ebuild
new file mode 100644
index 000000000000..a000b6debba9
--- /dev/null
+++ b/dev-python/fastimport/fastimport-0.9.11.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for parsing the fastimport VCS serialization format"
+HOMEPAGE="https://github.com/jelmer/python-fastimport"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+python_test() {
+ "${EPYTHON}" -m unittest -v fastimport.tests.test_suite ||
+ die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/fastimport/fastimport-0.9.8-r1.ebuild b/dev-python/fastimport/fastimport-0.9.8-r1.ebuild
new file mode 100644
index 000000000000..b5d142043174
--- /dev/null
+++ b/dev-python/fastimport/fastimport-0.9.8-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+
+inherit distutils-r1
+
+MY_PN="${PN#python-}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Library for parsing the fastimport VCS serialization format"
+HOMEPAGE="https://github.com/jelmer/python-fastimport"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ "${EPYTHON}" -m unittest -v fastimport.tests.test_suite \
+ || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/fastimport/fastimport-0.9.9.ebuild b/dev-python/fastimport/fastimport-0.9.9.ebuild
new file mode 100644
index 000000000000..a000b6debba9
--- /dev/null
+++ b/dev-python/fastimport/fastimport-0.9.9.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for parsing the fastimport VCS serialization format"
+HOMEPAGE="https://github.com/jelmer/python-fastimport"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+python_test() {
+ "${EPYTHON}" -m unittest -v fastimport.tests.test_suite ||
+ die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/fastimport/metadata.xml b/dev-python/fastimport/metadata.xml
new file mode 100644
index 000000000000..59cf5c8545b6
--- /dev/null
+++ b/dev-python/fastimport/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jelmer/python-fastimport</remote-id>
+ <bugs-to>https://github.com/jelmer/python-fastimport/issues</bugs-to>
+ <remote-id type="launchpad">python-fastimport</remote-id>
+ <remote-id type="pypi">fastimport</remote-id>
+ </upstream>
+</pkgmetadata>