summaryrefslogtreecommitdiff
path: root/dev-python/fastbencode/fastbencode-0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-07 22:17:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-07 22:17:58 +0100
commit4242446a1af7d38662da76b31d2e6254d64706ec (patch)
tree3fbdde39498070735cd6e04e15efffe46e77cfd1 /dev-python/fastbencode/fastbencode-0.2.ebuild
parente3184eb75ff6935e35462bfd59788feb985259e1 (diff)
gentoo auto-resync : 07:07:2023 - 22:17:58
Diffstat (limited to 'dev-python/fastbencode/fastbencode-0.2.ebuild')
-rw-r--r--dev-python/fastbencode/fastbencode-0.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/fastbencode/fastbencode-0.2.ebuild b/dev-python/fastbencode/fastbencode-0.2.ebuild
new file mode 100644
index 000000000000..33b5303ae6ab
--- /dev/null
+++ b/dev-python/fastbencode/fastbencode-0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Implementation of bencode with optional fast C extensions"
+HOMEPAGE="
+ https://github.com/breezy-team/fastbencode
+ https://pypi.org/project/fastbencode/
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest