summaryrefslogtreecommitdiff
path: root/dev-python/falcon/falcon-0.1.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/falcon/falcon-0.1.8.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/falcon/falcon-0.1.8.ebuild')
-rw-r--r--dev-python/falcon/falcon-0.1.8.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/falcon/falcon-0.1.8.ebuild b/dev-python/falcon/falcon-0.1.8.ebuild
new file mode 100644
index 000000000000..8ad9ec362b92
--- /dev/null
+++ b/dev-python/falcon/falcon-0.1.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# Python 2.6 is supported, but depends on ordereddict, which has been in
+# improvise for months and is a minimal package. If needed
+# please let me know. PyPy also works
+PYTHON_COMPAT=( python{2_7,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A supersonic micro-framework for building cloud APIs"
+HOMEPAGE="http://falconframework.org/ https://pypi.org/project/falcon/"
+SRC_URI="https://github.com/racker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cython test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/mimeparse[${PYTHON_USEDEP}]
+ cython? (
+ dev-python/cython[$(python_gen_usedep python{2_7,3_3})] )"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/cython[$(python_gen_usedep python{2_7,3_3})]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+src_prepare() {
+ if ! use cython; then
+ sed -i -e 's/if with_cython:/if False:/' setup.py \
+ || die 'sed failed.'
+ fi
+
+ # fix tests installation : potential file collision
+ sed -e 's@^where = tests@where = falcon/tests@g' -i setup.cfg || die
+ mv tests falcon/
+}