summaryrefslogtreecommitdiff
path: root/dev-python/falcon/falcon-0.1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/falcon/falcon-0.1.7.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/falcon/falcon-0.1.7.ebuild')
-rw-r--r--dev-python/falcon/falcon-0.1.7.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/falcon/falcon-0.1.7.ebuild b/dev-python/falcon/falcon-0.1.7.ebuild
deleted file mode 100644
index a1f2614f599d..000000000000
--- a/dev-python/falcon/falcon-0.1.7.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# Python 2.6 is supported, but depends on ordereddict, which has been in
-# improvise for months and is a minimal package. If needed
-# please let me know. PyPy also works
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A supersonic micro-framework for building cloud APIs"
-HOMEPAGE="http://falconframework.org/ https://pypi.org/project/falcon/"
-SRC_URI="https://github.com/racker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+cython test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
- dev-python/mimeparse[${PYTHON_USEDEP}]
- cython? (
- dev-python/cython[$(python_gen_usedep python{2_7,3_3})] )"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/cython[$(python_gen_usedep python{2_7,3_3})]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}] )"
-
-python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
-}
-
-src_prepare() {
- if ! use cython; then
- sed -i -e 's/if with_cython:/if False:/' setup.py \
- || die 'sed failed.'
- fi
-}