summaryrefslogtreecommitdiff
path: root/dev-python/falcon/falcon-0.1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/falcon/falcon-0.1.6.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/falcon/falcon-0.1.6.ebuild')
-rw-r--r--dev-python/falcon/falcon-0.1.6.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/falcon/falcon-0.1.6.ebuild b/dev-python/falcon/falcon-0.1.6.ebuild
deleted file mode 100644
index cc18513864ad..000000000000
--- a/dev-python/falcon/falcon-0.1.6.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# Python 2.6 is supported, but depends on ordereddict, which has been in
-# improvise for months and is a minimal package. If needed
-# please let me know. PyPy also works
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A supersonic micro-framework for building cloud APIs"
-HOMEPAGE="http://falconframework.org/ https://pypi.org/project/falcon/"
-SRC_URI="https://github.com/racker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+cython test"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
- cython? (
- dev-python/cython[$(python_gen_usedep python{2_7,3_3})] )"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/cython[$(python_gen_usedep python{2_7,3_3})]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}] )"
-
-python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
-}
-
-src_prepare() {
- if ! use cython; then
- sed -i -e 's/if with_cython:/if False:/' setup.py \
- || die 'sed failed.'
- fi
-}