summaryrefslogtreecommitdiff
path: root/dev-python/fakeredis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-20 20:21:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-20 20:21:39 +0000
commitdd03974882f85ca04e35cfbc97f7ff756f5d5c20 (patch)
tree4fabcc91c51083e19657dd0a557043e74468106e /dev-python/fakeredis
parentd542bd2ef95af892c7ef62be1489b0288b1df9e3 (diff)
gentoo auto-resync : 20:02:2023 - 20:21:39
Diffstat (limited to 'dev-python/fakeredis')
-rw-r--r--dev-python/fakeredis/Manifest2
-rw-r--r--dev-python/fakeredis/fakeredis-2.9.1.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index 2004c86fd7ed..5966031c602c 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1,5 +1,7 @@
DIST fakeredis-py-2.6.0.gh.tar.gz 151925 BLAKE2B 60538efa5de93436177aa019908f02affb9df9b2aaf1349e933da6f066f98aaa255bbdb3297645ad1dc3b67a57a61bb8081e476f451799b512719f5779c1218d SHA512 19a23be7a182f962e66686f3c4ec3a5b9fbc847d97e48f19fde11ae268f4a70de567ff2ca302a9fe0e7080de2215698cf5b2ff2febda5eef6748f3ec8d601720
DIST fakeredis-py-2.9.0.gh.tar.gz 165442 BLAKE2B e71780b273f1847454d0e6e89f3f97a9d4a81d86345857fced39413521202f299b90c8a218f12b15d79a3bb7c865d7b0280798920cfd93120a553511b3a343ff SHA512 2ddf2570e7f00647834f8f07a3fef6ec68d630ff93ddd5375dcc47a14a5a7bf430dbc4a1abfb38fa2b5e18f1aa1f4ef5413b39c4bb3ed9d167aa1729edfa9870
+DIST fakeredis-py-2.9.1.gh.tar.gz 165449 BLAKE2B 6d0b6937a460d5fd27270df5e2d88c332f4ab42e97430fc7efd5777e35051fd44f6ab01b013637ee17bccada199e126075e2efd5fa7e3fd0112739e0e14f3c31 SHA512 bf18454ec2ab62e49b4b3f93d494d7648b1b82d9ec3720e7418767dc4acdfc89e86df8ec1b9814ac69fb4b6fa13d25f2ed3a62f82f479d6614a994904f97f249
EBUILD fakeredis-2.6.0.ebuild 2074 BLAKE2B bbef8fdd31c1f1ba42a628aadd8688c2f6af4cb5894a1a68ff9313fb43ebf11edfdc1a878969d4c4fb94c553f6925a58504e16bd9cc34acec54c0d6629a78577 SHA512 d32ac3244d2909c5746190b7e0a66599ea0ebed1f3f59b61894674410dad70003faac790dbf794b77df665879b644d0a7990033d9077a9a065f11d451855047f
EBUILD fakeredis-2.9.0.ebuild 2010 BLAKE2B 435a9873d94081fcf3cda01959f4349d998ed02d986511cae95e700693a9dc1f4d7b002ffe75d8ec708856899dfc735c1fc5d567b603b0570c41c5ebb7165ef7 SHA512 a7b51f37fc01717d64fea5d00d3c2b9544b2d7d278ddee8c098f9bf56135288052beb357560f130df355b3367effc6eb7102116b61b4f0b08abb026bdbb39740
+EBUILD fakeredis-2.9.1.ebuild 2010 BLAKE2B 435a9873d94081fcf3cda01959f4349d998ed02d986511cae95e700693a9dc1f4d7b002ffe75d8ec708856899dfc735c1fc5d567b603b0570c41c5ebb7165ef7 SHA512 a7b51f37fc01717d64fea5d00d3c2b9544b2d7d278ddee8c098f9bf56135288052beb357560f130df355b3367effc6eb7102116b61b4f0b08abb026bdbb39740
MISC metadata.xml 373 BLAKE2B 1de33db59658e6190cd0346be58208cae6c9143a52f49dc289e68aaa0d860b5bd68dfb54f2e0b005f60a67f5caa430e2ce94fc69e64bd27e1bbebb07ad29e602 SHA512 24bfcf4919363fef45c182b6de66221e580ee0e9e99ce46e91b767655dc0b6f8a9fa6c3512ba84d1040698c43a0b6a853ad8d63c1ee5fbc00a1d192defb24db5
diff --git a/dev-python/fakeredis/fakeredis-2.9.1.ebuild b/dev-python/fakeredis/fakeredis-2.9.1.ebuild
new file mode 100644
index 000000000000..11e604ae7bad
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-2.9.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=fakeredis-py-${PV}
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/cunla/fakeredis-py/
+ https://pypi.org/project/fakeredis/
+"
+SRC_URI="
+ https://github.com/cunla/fakeredis-py/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/redis-5[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2[${PYTHON_USEDEP}]
+ <dev-python/sortedcontainers-3[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # also lupa
+ test/test_aioredis2.py::test_failed_script_error
+ # TODO
+ "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
+ "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_channels[StrictRedis]"
+ )
+ local EPYTEST_IGNORE=(
+ # these tests fail a lot...
+ test/test_hypothesis.py
+ )
+ local args=(
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+ epytest "${args[@]}"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}