summaryrefslogtreecommitdiff
path: root/dev-python/fakeredis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-13 00:12:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-13 00:12:52 +0000
commit965058196f44550f3bc491dd85064071e085b776 (patch)
tree8485c648f0ac19b27204c8b331c3619c93463cce /dev-python/fakeredis
parent0ec1e1dd7867c3dedcbea76c9b6e847d6b388c03 (diff)
gentoo auto-resync : 13:02:2025 - 00:12:52
Diffstat (limited to 'dev-python/fakeredis')
-rw-r--r--dev-python/fakeredis/Manifest2
-rw-r--r--dev-python/fakeredis/fakeredis-2.27.0.ebuild99
2 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index 8da39357ad38..68463dc0169b 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1,3 +1,5 @@
DIST fakeredis-2.26.2.tar.gz 150563 BLAKE2B 3def1db25e1bfe2bcc23dd0788963f57245c01d0e1810d6c36dac5186fc8024956cbb6be09667792ce5c55f015cce1f7fd12a2fe5c32a0eb8e305519bfa301fe SHA512 2316cdf555367103a83b36b52ebc1295918fe43ab158c0d9fa28fe8d159fe7d79f3b575c754ca4efde57007e88e1bd39b1dd4a8a8f6ef80ca034c615ce5031c0
+DIST fakeredis-2.27.0.tar.gz 157510 BLAKE2B aa427ce2bc0880aeea6fcb063cb98ff60caf600cae8b21c902a1d9193dd14d7a5f0daa7a3114c92d8eedeef84c936dba326c68e054a6c1dd775209d9055a88f3 SHA512 2fd33ca8e0a95e381cef5794beb009a20c9cf21c03954e86c56e634f00ea959615dc6021265f76c14236f219ee1bf606fbd43d46ab1db5dc3426b1c610020728
EBUILD fakeredis-2.26.2.ebuild 2561 BLAKE2B a7b37e40966b2e72466a7a620c0ba3d38464e139c69ca55f212b4578e68da1d2672d71c523c005a405f256d90e96e1200549cbe62243c7912fa94829ad1b25fb SHA512 ec6a1b3d73c9b241d9b2513004a88b90579bb6b144a84982347eb79ec0b443c2cebf8e1c487ad33b0ab58d60fa41925f05b5d6f8d0c0d13245d99d2f15fbb78d
+EBUILD fakeredis-2.27.0.ebuild 2650 BLAKE2B 2d44b3010f4cd240b09dfa6d18d536ca107ef7a11260c0b0a12fe718fd6a42f5d1a22c0448979eaf2131d027c456f7e77f3f7094769ed2c9889ccb7eb3388a12 SHA512 af26c84ba2c0d48d05521d3cc82ac1dbc9e0b233232365ff4380492aa5a1741a344ba5271e7ed10feb3011133758f7ed74eead5f8e0643751003c8436aabda1d
MISC metadata.xml 373 BLAKE2B 1de33db59658e6190cd0346be58208cae6c9143a52f49dc289e68aaa0d860b5bd68dfb54f2e0b005f60a67f5caa430e2ce94fc69e64bd27e1bbebb07ad29e602 SHA512 24bfcf4919363fef45c182b6de66221e580ee0e9e99ce46e91b767655dc0b6f8a9fa6c3512ba84d1040698c43a0b6a853ad8d63c1ee5fbc00a1d192defb24db5
diff --git a/dev-python/fakeredis/fakeredis-2.27.0.ebuild b/dev-python/fakeredis/fakeredis-2.27.0.ebuild
new file mode 100644
index 000000000000..9508f6092275
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-2.27.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 2020-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/cunla/fakeredis-py/
+ https://pypi.org/project/fakeredis/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.3[${PYTHON_USEDEP}]
+ <dev-python/sortedcontainers-3[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # https://github.com/cunla/fakeredis-py/issues/320
+ sed -i -e '/LICENSE/d' pyproject.toml || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # also lupa
+ test/test_aioredis2.py::test_failed_script_error
+ # TODO
+ "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
+ "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_channels[StrictRedis]"
+ test/test_mixins/test_set_commands.py::test_smismember_wrong_type
+ # new redis-server?
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_shardnumsub[StrictRedis]"
+ # json ext
+ test/test_json/test_json.py
+ test/test_json/test_json_arr_commands.py
+ # tdigest ext?
+ 'test/test_mixins/test_server_commands.py::test_command[FakeStrictRedis]'
+ # hexpire ext?
+ 'test/test_mixins/test_acl_commands.py::test_acl_cat[StrictRedis]'
+ )
+ local EPYTEST_IGNORE=(
+ # these tests fail a lot...
+ test/test_hypothesis.py
+ )
+ local args=(
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+ # Note: this package is not xdist-friendly
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p pytest_mock "${args[@]}"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6390
+
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}