summaryrefslogtreecommitdiff
path: root/dev-python/execnet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 19:42:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 19:42:07 +0100
commitfbd9734cedfe790955100b8e4ab3613457d77b1a (patch)
tree3eda83643563749dd2792dfb880eaeca1d061c18 /dev-python/execnet
parent6abaca02d36f161c81e2d5ee467719a89f88b2c5 (diff)
gentoo resync (3) : 24.07.2021
Diffstat (limited to 'dev-python/execnet')
-rw-r--r--dev-python/execnet/Manifest4
-rw-r--r--dev-python/execnet/execnet-1.8.1.ebuild48
-rw-r--r--dev-python/execnet/execnet-1.9.0.ebuild2
3 files changed, 2 insertions, 52 deletions
diff --git a/dev-python/execnet/Manifest b/dev-python/execnet/Manifest
index 0e3fec16fab2..608362aed171 100644
--- a/dev-python/execnet/Manifest
+++ b/dev-python/execnet/Manifest
@@ -1,5 +1,3 @@
-DIST execnet-1.8.1.tar.gz 173811 BLAKE2B 1d6277177908ccffe95973d34962856f6ef0a6d16c1e046f47a7ab0667b5e5c2867405a7a8bf36fb7be8e2fa0fd75b68375abdd9b70a1a1aaa641bdefadcd32d SHA512 183c89961b8b5db4eca5b64ff6b179f9faa19d26f04ad07740c818a471aedb02b2e7837fb7cedb6b1e4a538b0bd62cc4eff602dffe4c3c35bf826aa5a627afb2
DIST execnet-1.9.0.tar.gz 173884 BLAKE2B 622a1f47365bdea97ba53aee908faf990ef847e3641ab0590073cdd6eac3413d1517f16e8e5b73b56884f02aebb3142691ecf6113e14f9c49c9b0fef3ee3247c SHA512 d425e7b6f3708efecb5dfa2c36a837cb55f2c32cf2ec0c1dc11cd1ca6ea614d119d04908b84dd5a3593c87db35e71fee202f843665c853ac3538479f60c83d60
-EBUILD execnet-1.8.1.ebuild 1381 BLAKE2B 82bcf0a4966d9eaf5407940b7c614ff0ab21cefef474e7628d88c263de8f67e3a35c239b3d605c029a311909ac57faf8f158cbeeb578cd50f5acd3a39ec3baf8 SHA512 d29b6cfc9d9274ea99bbc3febeb7f7763612b4e870bbdae96ba54607736b8731d6ed98bd7751c5a4977e74295ff18568d811bfbb7e728ee9d0e32e50d1b41573
-EBUILD execnet-1.9.0.ebuild 1294 BLAKE2B ac541505f8a27dcedca15feee521fb85179826008e658a00ad09473881fe6a0e4b01d1d6523a2898d9dc47210426a33aaa03080d46447671ea111153390bacf3 SHA512 f2d43a54bbc535fa74e575a93e4d3e9e00bf6cbe15232c9ae774b9e8899856be622fd17c7b6a6c07226a3d4068849b92662c79a1df0cf226e93de0f7da9cc9dc
+EBUILD execnet-1.9.0.ebuild 1286 BLAKE2B 7d04689243fc54345102db2c66fe559adac511b8f90c0e36276ab4740f2bd6e6b6baa13278e03078de2dd6f04906e0d7ea1c59da6ed512b08336cf106784113c SHA512 13988d347781128a3ae8320fb522fb7776fa4b2439d4b9721c58693e9b9d4a699df7620b2a56931c75a34039123beb417b543d591c44f8d77551cd18133ea36f
MISC metadata.xml 441 BLAKE2B be64fae1f1acc10cff3492e6c2cd802f9f3bee83d646868d3dbe2336b35c791f8ec0be4aad6e89aaad167f03163740cdde543c5af6dc71c0780754f97a76f4af SHA512 9f17e1724f03b55e0313dd4b7528ef1f190258bd39efe35e144ad1807f4037a08e4302f749153f511c1bd0ab01a885e3700eb3ead4764d44161c0f7080a55673
diff --git a/dev-python/execnet/execnet-1.8.1.ebuild b/dev-python/execnet/execnet-1.8.1.ebuild
deleted file mode 100644
index bae6991e7b0f..000000000000
--- a/dev-python/execnet/execnet-1.8.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Rapid multi-Python deployment"
-HOMEPAGE="https://codespeak.net/execnet/
- https://pypi.org/project/execnet/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND=">=dev-python/apipkg-1.4[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx doc
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -i -r 's:(,[[:space:]]*|)"eventlet":: ; s:(,[[:space:]]*|)"gevent"(,|)::' \
- testing/conftest.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local deselect=(
- # needs python2.7 with apipkg?
- 'testing/test_termination.py::test_close_initiating_remote_no_error[python2.7]'
- # tries to run python2
- testing/test_channel.py::TestStringCoerce::test_3to2
- testing/test_gateway.py::TestStringCoerce::test_3to2
- # does not like Gentoo defaults
- testing/test_gateway.py::TestPopenGateway::test_dont_write_bytecode
- # almost all tests call py2, not worth filtering for the rest
- testing/test_serializer.py
- )
-
- pytest -vv ${deselect[@]/#/--deselect } ||
- die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/execnet/execnet-1.9.0.ebuild b/dev-python/execnet/execnet-1.9.0.ebuild
index cd56d3f62b74..6296f67afd08 100644
--- a/dev-python/execnet/execnet-1.9.0.ebuild
+++ b/dev-python/execnet/execnet-1.9.0.ebuild
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]"