summaryrefslogtreecommitdiff
path: root/dev-python/execnet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/execnet
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/execnet')
-rw-r--r--dev-python/execnet/Manifest5
-rw-r--r--dev-python/execnet/execnet-1.4.1.ebuild51
-rw-r--r--dev-python/execnet/execnet-1.5.0.ebuild51
-rw-r--r--dev-python/execnet/metadata.xml19
4 files changed, 126 insertions, 0 deletions
diff --git a/dev-python/execnet/Manifest b/dev-python/execnet/Manifest
new file mode 100644
index 000000000000..e15d945619f2
--- /dev/null
+++ b/dev-python/execnet/Manifest
@@ -0,0 +1,5 @@
+DIST execnet-1.4.1.tar.gz 171041 BLAKE2B 7e51320969b0203a8ff55d69364c3fa69d747d67f5dd3a3aaeab7700192d63918bbc11ae29a1e26e466078f1ca87ea00ddcfe0f98132921bacfc95671c3ad7c7 SHA512 e8c0c32e873f8585ff4d4da3b9cbd40046479370f5653f67a98c9029d4535a619731d1b825332fe4af4dc5ebc9ab11ee879ef45df07f08943b1e1685f2255790
+DIST execnet-1.5.0.tar.gz 168497 BLAKE2B 1777f3a72cbf75e5bdef90cdda956a5d8101980f299a1bade6d6faeec52e1026a18a87c8b6b08c8d27073acedacd38473f68c6823908701816b4725edd3d9fb0 SHA512 ca2b571fafdf8f68b3cc7a04ee326e3255828d4cde28ead65d0cef325569c3a6dee09359e525152248038de65326ffc6b75c8362f53aa5c0b3f736eb596cb2d9
+EBUILD execnet-1.4.1.ebuild 1263 BLAKE2B 80a6575e5d030309388a6dc3f4a6e14a528aeff72bc0b6fc9ec7cc1657685ec98374662b5bc8218b728d10f726f703ea1d92ae664cf3081e8b9302f0c4ce16c2 SHA512 f33be0f997bb2e2542a4f9bc7f4abd836fafc013314bb4bd2803d39a6fd3e043183950a42f11d3768977c62262ae1948b660d2ca3a31498d388a30050c1afd4d
+EBUILD execnet-1.5.0.ebuild 1285 BLAKE2B 701047f7547c4199364374a5f716c1b503966dcf6d4d67dff836af5e2bf52cd5e8900385dd49c15bd8ceefff42c4244f1669ebfddc6fd18faa77cde1749272c1 SHA512 7b5111a48bf438dd0897f3e0694723f4bc3d23fa7ef25ccdf831c91b0b3b7740fca2803a9ab9de7ba5cc0e45e9e83553cf117be73c683d1af859b453d8adf6e1
+MISC metadata.xml 541 BLAKE2B a1e9f563cf102eef9dcde4800cca44d354e4cb7d77c20422074296c3eb2df1baa46f4cf5a803b07f454e98f902124f185ff24224f499d50577a2c2ed3cdbe21b SHA512 8afb04a008ce5704560a8f984dc5662abb01244b93bbf655bf0c66365a125a07dd1adca26f75df2bc89f923409b3687bc610f0ed739879a6f66167b799963091
diff --git a/dev-python/execnet/execnet-1.4.1.ebuild b/dev-python/execnet/execnet-1.4.1.ebuild
new file mode 100644
index 000000000000..256f383e1107
--- /dev/null
+++ b/dev-python/execnet/execnet-1.4.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Rapid multi-Python deployment"
+HOMEPAGE="http://codespeak.net/execnet/ https://pypi.org/project/execnet/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/apipkg-1.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+#PATCHES=( "${FILESDIR}"/1.2.0-tests.patch )
+RESTRICT="test"
+
+python_prepare_all() {
+ # Remove doctest that access an i'net site
+ rm doc/example/test_info.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ # https://bitbucket.org/hpk42/execnet/issue/10
+ unset PYTHONDONTWRITEBYTECODE
+ py.test testing || die "Tests fail with ${EPYTHON}"
+
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/execnet/execnet-1.5.0.ebuild b/dev-python/execnet/execnet-1.5.0.ebuild
new file mode 100644
index 000000000000..1041eb5b2767
--- /dev/null
+++ b/dev-python/execnet/execnet-1.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Rapid multi-Python deployment"
+HOMEPAGE="http://codespeak.net/execnet/ https://pypi.org/project/execnet/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/apipkg-1.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+#PATCHES=( "${FILESDIR}"/1.2.0-tests.patch )
+RESTRICT="test"
+
+python_prepare_all() {
+ # Remove doctest that access an i'net site
+ rm doc/example/test_info.rst || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ # https://bitbucket.org/hpk42/execnet/issue/10
+ unset PYTHONDONTWRITEBYTECODE
+ py.test testing || die "Tests fail with ${EPYTHON}"
+
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/execnet/metadata.xml b/dev-python/execnet/metadata.xml
new file mode 100644
index 000000000000..780195f0f3ee
--- /dev/null
+++ b/dev-python/execnet/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ Interact with Python interpreters
+ across version, platform and network barriers.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">execnet</remote-id>
+ </upstream>
+</pkgmetadata>