summaryrefslogtreecommitdiff
path: root/dev-python/exceptiongroup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-04 21:16:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-04 21:16:38 +0000
commitf932718a139f93e19a6883c061f81b365a408592 (patch)
tree216b44e4ea101b2d02ea32782355ed127f7b1df4 /dev-python/exceptiongroup
parentf5f1e7d30401ef31b8776c96a80cf5caae0a4e81 (diff)
gentoo auto-resync : 04:11:2022 - 21:16:37
Diffstat (limited to 'dev-python/exceptiongroup')
-rw-r--r--dev-python/exceptiongroup/Manifest2
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.0.1.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/exceptiongroup/Manifest b/dev-python/exceptiongroup/Manifest
index 2d185e59e57f..ac7e00d266e6 100644
--- a/dev-python/exceptiongroup/Manifest
+++ b/dev-python/exceptiongroup/Manifest
@@ -1,3 +1,5 @@
DIST exceptiongroup-1.0.0.gh.tar.gz 19766 BLAKE2B 2c4aa2c7c096b91971872b2236fad211a1bd7cb8ae921f5a0255b5a534eefdb5033bbca4c562ff7045acf30e13371a38d52851749cd5bca4df6adfe359a43012 SHA512 e2e05066c0c7664bb36696737c0c33abd811637c5f0ae7e70a20525283d4db4667fa814b15cb6b21165416ae1a0c47f22250a2ed9be4be99b6237e0c1b45fdd4
+DIST exceptiongroup-1.0.1.gh.tar.gz 20267 BLAKE2B 1438e88a51034acd8b032339097640862da323dc46aaab4f64e53a3e8c3ce8a7bbda16cc72eff9c4f3ac44d8c239b9e51d3561781bbd0ed88fe9e1db78e95c2b SHA512 79a678b6d3d152334ff593d15047e4b4c8714d50bd667ff2c878617512fe78b0c1d9df113db221d9ac7ea1e4522427747d85e26ae2d46b16f15538e1a638cc38
EBUILD exceptiongroup-1.0.0.ebuild 762 BLAKE2B d9157df63bd73187f1abe6b2b9bc81d1920177ddcc039d06cd8f42e5a3904b9fedb695f047aafe2468b0dce6448d6db3ffb1d7856bd149f1136782a3b0333c5f SHA512 fb93d9f4e6fdbc4f7363b53777d005378d5f9cf088acb72b7cd532aaf38420c1892d4a228c9a8575f1e389c52dabdef40a3d22a382bfd738ce9b0fbc6558b20f
+EBUILD exceptiongroup-1.0.1.ebuild 770 BLAKE2B b0bd0b8fb1edb61e570eac329219319ead6fb6273aaab2e828446f56d6534a8753fefdbd059ffab172a746d1f60ceaf7fbc281ea466af11d37f9bda8da38e598 SHA512 ddbf7e5089ad4d90183f949b1bf9122a4f86189dd98a3e53fc0d515bf1f261e7c64c71a6ef94b11a833ea63b228b3725e4f38050ce44be26f1363a0fd8023554
MISC metadata.xml 384 BLAKE2B 248abcb5fc08c91396cdbff52e5c3e4f6cce2aa273cfd52b48ee13de9ccdaecd09e9a436ed79f258d15d8d4583fe5995e054010c909a522f47e6866e55b3458f SHA512 c631c69438059cb2a6c80e595e45fac904d32dfb53f8be183142f1195d3a3b9bc14bc240f0808e14f47d31beb1887ad82ee79c5f1847c8e6b59dbfeea7913c8b
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.0.1.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.0.1.ebuild
new file mode 100644
index 000000000000..b848cb3eea31
--- /dev/null
+++ b/dev-python/exceptiongroup/exceptiongroup-1.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit_scm
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="Backport of PEP 654 (exception groups)"
+HOMEPAGE="
+ https://github.com/agronholm/exceptiongroup/
+ https://pypi.org/project/exceptiongroup/
+"
+SRC_URI="
+ https://github.com/agronholm/exceptiongroup/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT PSF-2.4"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV/_}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}