summaryrefslogtreecommitdiff
path: root/dev-python/exceptiongroup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/exceptiongroup
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/exceptiongroup')
-rw-r--r--dev-python/exceptiongroup/Manifest5
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.0.0_rc3.ebuild34
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.0.0_rc5.ebuild34
-rw-r--r--dev-python/exceptiongroup/metadata.xml11
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/exceptiongroup/Manifest b/dev-python/exceptiongroup/Manifest
new file mode 100644
index 000000000000..1522105b48ce
--- /dev/null
+++ b/dev-python/exceptiongroup/Manifest
@@ -0,0 +1,5 @@
+DIST exceptiongroup-1.0.0rc3.gh.tar.gz 15973 BLAKE2B de9e6e272beca083a6bfe4bd85f9a450e7ec379b903dade27b0ea358762431dfad62d845f5285ec37ebd4f5458105fa6c9be3e075fc6122613088f023d31b04b SHA512 c3f55aae05635aa3360dbf21fbe0005df64b32c9a9521ef7d6026f9746522e4bff485784114913777b828612c20d8385dab49e5d1ffb642999c1f8180b94b2c5
+DIST exceptiongroup-1.0.0rc5.gh.tar.gz 16454 BLAKE2B 55af4d2240e4a5567f5669d15e8507c454d47c1f7d8f72212afeecfa37e0c4a6b36f9176a87a48d3f9edf0628a8c99863670d24aca3770dd88abaa463784c731 SHA512 dd5ee895b4531524c4f0dfaedf818ac76a1b6fe74cd75bbce824b6a0d2b981673ffd6ba36f71b5dacf3e17c89d196a258400d04a64c71f28c221d7fb0f934ab7
+EBUILD exceptiongroup-1.0.0_rc3.ebuild 695 BLAKE2B 1d9de079da97cb77b753f96b59674c85c4c738d6e1feb342953639ecd25ca4ef952fb6ecf6fd66688f51fad080507f144db1836cbec7a5eb6403e04ba9cfa71e SHA512 45790a03b2225bd273c4544a18c7cd9f10eaece3fcf14099a70df0cd710e9dc8b01872d1b2d5bf907ff51234dbb0a079b58d76147a53573767952c0340ea0d86
+EBUILD exceptiongroup-1.0.0_rc5.ebuild 695 BLAKE2B 1d9de079da97cb77b753f96b59674c85c4c738d6e1feb342953639ecd25ca4ef952fb6ecf6fd66688f51fad080507f144db1836cbec7a5eb6403e04ba9cfa71e SHA512 45790a03b2225bd273c4544a18c7cd9f10eaece3fcf14099a70df0cd710e9dc8b01872d1b2d5bf907ff51234dbb0a079b58d76147a53573767952c0340ea0d86
+MISC metadata.xml 360 BLAKE2B accdc2d9dc39a31238555b937189f135482f2094a570396a741ba6202a1243ad46c99003e829e59e4e5fd0db0a01b050cc0e385bf28b44892e3e3c5615351028 SHA512 d740125cf760309a4dc5de1981b5ad704e880c37588e8a0e17816709065d80ad2ffecb3b5e50725b5665a38594a53f9659c17b35eb34bffbb06d11b830d740cd
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.0.0_rc3.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.0.0_rc3.ebuild
new file mode 100644
index 000000000000..2571619d98a3
--- /dev/null
+++ b/dev-python/exceptiongroup/exceptiongroup-1.0.0_rc3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit_scm
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="Backport of PEP 654 (exception groups)"
+HOMEPAGE="
+ https://github.com/agronholm/exceptiongroup/
+ https://pypi.org/project/exceptiongroup/
+"
+SRC_URI="
+ https://github.com/agronholm/exceptiongroup/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT PSF-2.4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV/_}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.0.0_rc5.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.0.0_rc5.ebuild
new file mode 100644
index 000000000000..2571619d98a3
--- /dev/null
+++ b/dev-python/exceptiongroup/exceptiongroup-1.0.0_rc5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit_scm
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="Backport of PEP 654 (exception groups)"
+HOMEPAGE="
+ https://github.com/agronholm/exceptiongroup/
+ https://pypi.org/project/exceptiongroup/
+"
+SRC_URI="
+ https://github.com/agronholm/exceptiongroup/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT PSF-2.4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV/_}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
diff --git a/dev-python/exceptiongroup/metadata.xml b/dev-python/exceptiongroup/metadata.xml
new file mode 100644
index 000000000000..417343e0fae4
--- /dev/null
+++ b/dev-python/exceptiongroup/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">agronholm/exceptiongroup</remote-id>
+ <remote-id type="pypi">exceptiongroup</remote-id>
+ </upstream>
+</pkgmetadata>