summaryrefslogtreecommitdiff
path: root/dev-python/evdev
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-27 22:42:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-27 22:42:39 +0000
commit417348c68a53a9317b6afbf343381518a405f682 (patch)
tree2436ae4cc1751690d448293f351e3fa529909437 /dev-python/evdev
parent4f5eafd9cc8e9b40e20b0a1abd96f1bcd634d0a0 (diff)
gentoo auto-resync : 27:01:2025 - 22:42:39
Diffstat (limited to 'dev-python/evdev')
-rw-r--r--dev-python/evdev/Manifest3
-rw-r--r--dev-python/evdev/evdev-1.8.0.ebuild49
-rw-r--r--dev-python/evdev/files/evdev-1.8.0-test.patch22
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/evdev/Manifest b/dev-python/evdev/Manifest
index 86327ffaab6b..ae3ce5ac3b61 100644
--- a/dev-python/evdev/Manifest
+++ b/dev-python/evdev/Manifest
@@ -1,3 +1,6 @@
+AUX evdev-1.8.0-test.patch 780 BLAKE2B 63049c2740f39ef3b9df5adb4ae140985856e2027224bd3d540e790b2e7e5ae0d4088b64049c54f7232d8eda73b60e75059de3bc369f9a0d8bfabd5a95994dc5 SHA512 bdcd4e3795d02375262a420b792cfa4b9219486b95a7129c4c1c614fe97b792fc4b19990e04f0022b237a14420a335f17d935501c48289c0cc16fe5021d8d442
DIST python-evdev-1.7.1.gh.tar.gz 88275 BLAKE2B 334f70785411bd0e8d348ddeb0a6a728dbfd5c3604a19e7153c47d6868f76b0d3c10317230b0d6874cc14b3765d0e520d932c551842bd0d758b7a735b30ba7cb SHA512 802ba7c252a8817c60480db90b28e89b8356580d7b7f6a35725c70fcacbcabb3d3216330f6639ece940d901434cf1617d7682d344b7428fd5c5b6ab940700ff8
+DIST python-evdev-1.8.0.gh.tar.gz 47568 BLAKE2B 489ebf6eecf2a7212b67f1393e105bbb801236f039bcc2adb805049a4941fc4d064a22b0928c69fa907197c444b49e7446b7641c4b19c1ff10b1fc4ad1a0d1ab SHA512 86b2c08068863473e89f1455ff29f049786c292eaf1bdd44ad584054280aa2d40182640d67301653251ed13b2e7414bc81b7afc6b978a392d95fdce786f23e36
EBUILD evdev-1.7.1.ebuild 896 BLAKE2B f0818657d3dc94a9f19f826cd3480739ad1a8d1f2e50f2bfd672530b263e197a5ac0cff81abca19c8a87fb582672321203e7732fc2d4bb11283019b4bb07d330 SHA512 e4d071acecd059f9605917a33e25b94f73fd6a63679b85a8cd0b3bf941b70002c78feedf7f03464351ad4f06a0465fcde8efa450e6ab52e7021d37fa6d867967
+EBUILD evdev-1.8.0.ebuild 1008 BLAKE2B 601fe86a589f26fcbf434263587859c08c2bf926ef927b67c4f074c728cd1090fa5d16bc6f4baa81f57ea8c6e37705f9044855d8f88cf2656ceed027ac82ca03 SHA512 3aa8fbbffb4fb9f2831b1c1610fc42defb676dcea89451f3cc97c10a012071832d7ef3a24cb06e377a68bd85fab5b0f183f620a4c5435d001212e9883a6774a5
MISC metadata.xml 369 BLAKE2B 3db50cf2308091023bd5dd7768e1ff0af97124c5009efb710defc139b2809a804472969055cd0d120399d14b78d7da9dd92ca44b7de35fbf0e4cda2838ceb911 SHA512 1ceaa34af50744cd1108c990891c7105fa5373242b02fdd9b25718a6275b90d787a948b78ab4a17f0cfc168ba0c9f98d4c5b1e33997a0d751f7ffaed0b7189da
diff --git a/dev-python/evdev/evdev-1.8.0.ebuild b/dev-python/evdev/evdev-1.8.0.ebuild
new file mode 100644
index 000000000000..3998e22d71b7
--- /dev/null
+++ b/dev-python/evdev/evdev-1.8.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+MY_P=python-evdev-${PV}
+DESCRIPTION="Python library for evdev bindings"
+HOMEPAGE="
+ https://python-evdev.readthedocs.io/
+ https://github.com/gvalkov/python-evdev/
+ https://pypi.org/project/evdev/
+"
+SRC_URI="
+ https://github.com/gvalkov/python-evdev/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # upstream 27eb2ff11bb6b41fa0cfcff4f80d6c26d4b65742 (post 1.8.0)
+ "${FILESDIR}/${P}-test.patch"
+)
+
+EPYTEST_DESELECT=(
+ tests/test_uinput.py
+)
+
+python_configure_all() {
+ esetup.py build_ecodes \
+ --evdev-headers \
+ "${ESYSROOT}/usr/include/linux/input.h:${ESYSROOT}/usr/include/linux/input-event-codes.h"
+}
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}
diff --git a/dev-python/evdev/files/evdev-1.8.0-test.patch b/dev-python/evdev/files/evdev-1.8.0-test.patch
new file mode 100644
index 000000000000..aa155da3398a
--- /dev/null
+++ b/dev-python/evdev/files/evdev-1.8.0-test.patch
@@ -0,0 +1,22 @@
+From 27eb2ff11bb6b41fa0cfcff4f80d6c26d4b65742 Mon Sep 17 00:00:00 2001
+From: Georgi Valkov <georgi.t.valkov@gmail.com>
+Date: Sat, 25 Jan 2025 18:04:39 +0100
+Subject: [PATCH 1/2] Fix tests
+
+---
+ tests/test_util.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_util.py b/tests/test_util.py
+index 5a979df..7112927 100644
+--- a/tests/test_util.py
++++ b/tests/test_util.py
+@@ -6,7 +6,7 @@ def test_match_ecodes_a():
+ assert res == {1: [372, 418, 419, 420]}
+ assert dict(util.resolve_ecodes_dict(res)) == {
+ ("EV_KEY", 1): [
+- (["KEY_FULL_SCREEN", "KEY_ZOOM"], 372),
++ (("KEY_FULL_SCREEN", "KEY_ZOOM"), 372),
+ ("KEY_ZOOMIN", 418),
+ ("KEY_ZOOMOUT", 419),
+ ("KEY_ZOOMRESET", 420),