summaryrefslogtreecommitdiff
path: root/dev-python/etuples/etuples-0.3.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-03 16:19:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-03 16:19:20 +0100
commit312456186919deebd1ea3b34b9e26b1e15ebd5b6 (patch)
tree9f41dbee43e2392f0e58ed3b9f43ce41e8d18fce /dev-python/etuples/etuples-0.3.7.ebuild
parentfe2f8d9da0555e4ed15cc203d8dd99dd60b3117e (diff)
gentoo auto-resync : 03:09:2022 - 16:19:20
Diffstat (limited to 'dev-python/etuples/etuples-0.3.7.ebuild')
-rw-r--r--dev-python/etuples/etuples-0.3.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/etuples/etuples-0.3.7.ebuild b/dev-python/etuples/etuples-0.3.7.ebuild
new file mode 100644
index 000000000000..bf565f12b12c
--- /dev/null
+++ b/dev-python/etuples/etuples-0.3.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python S-expression emulation using tuple-like objects"
+HOMEPAGE="
+ https://pypi.org/project/etuples/
+ https://github.com/pythological/etuples/
+"
+SRC_URI="
+ https://github.com/pythological/etuples/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cons[${PYTHON_USEDEP}]
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest