summaryrefslogtreecommitdiff
path: root/dev-python/etuples/etuples-0.3.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-02 16:16:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-02 16:16:41 +0100
commit2982504d287f7f91eade76902f11e691f8181071 (patch)
tree6c5dedf9f5c14d738b335a8d18ec5aed6ddad01f /dev-python/etuples/etuples-0.3.6.ebuild
parent02fbebe9426ee05ab39e9b5a56e3529e64160ef6 (diff)
gentoo auto-resync : 02:09:2022 - 16:16:41
Diffstat (limited to 'dev-python/etuples/etuples-0.3.6.ebuild')
-rw-r--r--dev-python/etuples/etuples-0.3.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/etuples/etuples-0.3.6.ebuild b/dev-python/etuples/etuples-0.3.6.ebuild
new file mode 100644
index 000000000000..bf565f12b12c
--- /dev/null
+++ b/dev-python/etuples/etuples-0.3.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python S-expression emulation using tuple-like objects"
+HOMEPAGE="
+ https://pypi.org/project/etuples/
+ https://github.com/pythological/etuples/
+"
+SRC_URI="
+ https://github.com/pythological/etuples/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cons[${PYTHON_USEDEP}]
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest