summaryrefslogtreecommitdiff
path: root/dev-python/etsdevtools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/etsdevtools
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/etsdevtools')
-rw-r--r--dev-python/etsdevtools/Manifest5
-rw-r--r--dev-python/etsdevtools/etsdevtools-4.0.2-r1.ebuild48
-rw-r--r--dev-python/etsdevtools/metadata.xml33
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/etsdevtools/Manifest b/dev-python/etsdevtools/Manifest
new file mode 100644
index 000000000000..e4fee1e530c5
--- /dev/null
+++ b/dev-python/etsdevtools/Manifest
@@ -0,0 +1,5 @@
+DIST etsdevtools-4.0.2.tar.gz 4222266 SHA256 6b0e8906deab4cbb449e2be559526f0a958c062678b70b04a6978a7c00fb6310 SHA512 41e88997d74397f8780c47c87080629661790aefaabeb9463503f7a7331aefbb7ba42a9754382f43adf6143c28db999af70b287a221b8cdbd44b2b7443b2b23d WHIRLPOOL 9dedd133088d6b40d1f923c984371aecc2fc0ebd4a930bec5f4948e3e5c304b2a41b6e6c2749a49dc77b24f74872aa93311321a8c4daa83da2f0098848ab7662
+EBUILD etsdevtools-4.0.2-r1.ebuild 1136 SHA256 430adc73c4b195857d91d03704687971ec2e337773d792f1ed27023ad630f873 SHA512 3fe95ebec78351f0e8980b52e96e6f7579f24500806c8beb943e52d8338670159b305a86740528d0880d466eaa24399a0406ac8a944783cda34b5f8b8e161256 WHIRLPOOL 3f71d8b29101dcd986c3fd9ed1a992435361bc94373c10a474d82f1f7368eae8313e46a93b8edf33a06401ddcf7b291c90ea229cc5c1acfcd68d8368eb42181b
+MISC ChangeLog 2769 SHA256 f166ae69f4ce5710029fb55d5bba05098717fbe6459a9838ae3fc4dd83239305 SHA512 b488d3cfc104e469b913c059d1d654807d6f7c900d2a9abfa22c1e4c376b2a9340f7d1b7d6a03498f18684ae3324718a2569d9932529c64bd0895fa3c7070036 WHIRLPOOL 41b1667e520c27ec017f3ce72eac5710638ec809dbfa269437b2c20dbf10fc87dffca6171984652cdd16ed4547a01df5de6aa157c22a4d3194f194c22de8378d
+MISC ChangeLog-2015 3925 SHA256 9bb8175d505fadf683f7199cd58c7cc2006427d36440eefdcb34463dc9f714e0 SHA512 44d33c0b12d3c1d7b7570dadfb0622007c93377efc96428b4cbf8141ec479db0b20c89d718f44d997ad1c1d663e94d8be822728c005ef7929b56cde4c2c7dae0 WHIRLPOOL 6671d0872390601b722de9222a8f3ab9e003379ac9dfe268bfb0aea31fd51dac1548fc212c42f6f1efa366f619a43a820f114f5467b186e2297ad0be2e609b54
+MISC metadata.xml 1714 SHA256 cbc984105d606e980073283f4660b598dad61e4c1377eeee5c114c784dede6cc SHA512 e51be7af099abfdcdff6cf10c05ee2054622058094c8548d49fb82a887821e4adc80b6f1836a780af6c5363da270ea6332842881056a39c2c01d402056ecf1d0 WHIRLPOOL f2e0d41f32ad1452d896b8b770ca7b85161e4bf9fe67cef9c3936f1c76c8dabbf80d0f3042fddf23c43367864de8f2e9ade13411f6e79a35a2952428acd94538
diff --git a/dev-python/etsdevtools/etsdevtools-4.0.2-r1.ebuild b/dev-python/etsdevtools/etsdevtools-4.0.2-r1.ebuild
new file mode 100644
index 000000000000..b342be12e09d
--- /dev/null
+++ b/dev-python/etsdevtools/etsdevtools-4.0.2-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Tools to support Python development"
+HOMEPAGE="http://code.enthought.com/projects/dev_tools.php https://pypi.python.org/pypi/etsdevtools"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/traits[${PYTHON_USEDEP}]"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ >=dev-python/traitsui-4[${PYTHON_USEDEP}]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ x11-apps/xhost
+ )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ VIRTUALX_COMMAND="nosetests -v" virtualmake
+}
+
+python_install_all() {
+ find -name "*LICENSE*.txt" -delete
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/etsdevtools/metadata.xml b/dev-python/etsdevtools/metadata.xml
new file mode 100644
index 000000000000..c950c177b248
--- /dev/null
+++ b/dev-python/etsdevtools/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ The ETSDevTools project from the Enthought Tool Suite includes a
+ set of packages that can be used during the development of a
+ software project, for understanding, debugging, testing, and
+ inspecting code:
+ * Enthought Developer Tool Suite (enthought.developer): A
+ collection of utilities, designed to ease the development and
+ debugging of Traits-based programs. They can be used as plug-ins
+ to your Envisage application while you are developing it, and then
+ removed when you are ready to release it.
+ * Endo: A Traits-aware tool for processing API documentation of
+ Python code. It extracts not only docstrings, but also plain
+ comments that immediately precede variable assignments (both
+ module-scope variables and class attributes).
+ * enthought.guitest: A collection of utilities for unit testing
+ user interfaces (translation of the Perl X11::GUITest and
+ Win32::GuiTest modules).
+ * enthought.testing: Scripts related to running unit tests, based
+ on testoob, and also allowing running test suites in separate
+ processes and aggregating the results.
+ * enthought.debug: A collection of debugging tools, not to be
+ included in production code. NOTE: These tools are functional, but
+ are not being developed or supported. They have been mainly
+ superceded by the tools in the Enthought Developer Tool Suite.
+ </longdescription>
+</pkgmetadata>