summaryrefslogtreecommitdiff
path: root/dev-python/et_xmlfile/et_xmlfile-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/et_xmlfile/et_xmlfile-1.1.0.ebuild
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/et_xmlfile/et_xmlfile-1.1.0.ebuild')
-rw-r--r--dev-python/et_xmlfile/et_xmlfile-1.1.0.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/et_xmlfile/et_xmlfile-1.1.0.ebuild b/dev-python/et_xmlfile/et_xmlfile-1.1.0.ebuild
index a44d680ba7b8..84687c138ef7 100644
--- a/dev-python/et_xmlfile/et_xmlfile-1.1.0.ebuild
+++ b/dev-python/et_xmlfile/et_xmlfile-1.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
@@ -11,7 +11,9 @@ MY_PV=${PV%.0}
MY_P=${PN}-${MY_PV}
DESCRIPTION="An implementation of lxml.xmlfile for the standard library"
-HOMEPAGE="https://pypi.org/project/et-xmlfile/"
+HOMEPAGE="
+ https://pypi.org/project/et-xmlfile/
+ https://foss.heptapod.net/openpyxl/et_xmlfile/"
SRC_URI="
https://foss.heptapod.net/openpyxl/et_xmlfile/-/archive/${MY_PV}/${MY_P}.tar.gz"
S=${WORKDIR}/${MY_P}
@@ -23,3 +25,4 @@ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
+distutils_enable_sphinx doc