summaryrefslogtreecommitdiff
path: root/dev-python/et_xmlfile/et_xmlfile-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/et_xmlfile/et_xmlfile-1.1.0.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/et_xmlfile/et_xmlfile-1.1.0.ebuild')
-rw-r--r--dev-python/et_xmlfile/et_xmlfile-1.1.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/et_xmlfile/et_xmlfile-1.1.0.ebuild b/dev-python/et_xmlfile/et_xmlfile-1.1.0.ebuild
new file mode 100644
index 000000000000..a44d680ba7b8
--- /dev/null
+++ b/dev-python/et_xmlfile/et_xmlfile-1.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+MY_PV=${PV%.0}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="An implementation of lxml.xmlfile for the standard library"
+HOMEPAGE="https://pypi.org/project/et-xmlfile/"
+SRC_URI="
+ https://foss.heptapod.net/openpyxl/et_xmlfile/-/archive/${MY_PV}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest