summaryrefslogtreecommitdiff
path: root/dev-python/errorhandler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/errorhandler
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/errorhandler')
-rw-r--r--dev-python/errorhandler/Manifest5
-rw-r--r--dev-python/errorhandler/errorhandler-1.1.1-r2.ebuild49
-rw-r--r--dev-python/errorhandler/files/docs.patch12
-rw-r--r--dev-python/errorhandler/files/errorhandler-1.1.1-test.patch9
-rw-r--r--dev-python/errorhandler/metadata.xml11
5 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/errorhandler/Manifest b/dev-python/errorhandler/Manifest
new file mode 100644
index 000000000000..f5dcf691372a
--- /dev/null
+++ b/dev-python/errorhandler/Manifest
@@ -0,0 +1,5 @@
+AUX docs.patch 358 BLAKE2B 14a004cd902c0c0acdf0d8e2bd595729beed4a395c249e8b204d97acdc7ddbb11e2653265b11c9229775f37857a227a89517abd7b91d7dfd8935d3d9bda1f836 SHA512 fad104f167d633644ec8f21d8888e8bfe5ab7eaa8c82b30ae2d209d64746ac4912ece042ea942bc7578c51423d1472820a58eafedfd34b644899362b94d84469
+AUX errorhandler-1.1.1-test.patch 386 BLAKE2B 13699a957b74822e9e1cb6ddce1b42fad2dd9c6b92cd82e44d27520b514d6e3def9fe487a95dfe91340dd8db02748a8430dccb433134c32c7bb6715c8364c3d7 SHA512 c6ce048411e70f8f2cb5bdbba5ee2799b09dc036f5620f03b87c0185bd12759cce03d7dc9379602546693daa05d3fb9b15c4aed8e18c265bee73272bb4a16f52
+DIST errorhandler-1.1.1.tar.gz 8321 BLAKE2B f2b0cc9dcf9bf86c1b89356f66fca2d64d49acb919ae6bfc18b1dcb013cb67a358f2f81d47cd1c3bca601c85fc3bb5f870e1cc2452d25b187309a844efed15b3 SHA512 a2f875537103086be956becfdac25a43a646a89b404b6a7a2a243c6d2ddbc29d55948b781529d0a0fa82b163187747f3396b62ed0be98d39834de038cc4a1fd2
+EBUILD errorhandler-1.1.1-r2.ebuild 1129 BLAKE2B b04eb174321a2f870f1b8e0006f095dae3e6058f25db1c62a0672421437878844a5388640dcdb35e34eefda845b443068cf51e12d76ffeceb22995c38d42d098 SHA512 ed41fdced7f976173391192c0768f6da7e417147a981b6b2ac2ffa9fc2621e6b4ac1c2c563402cb76de9b14d6c7dbba1122e7609dff33dd4beafe599af96ed9d
+MISC metadata.xml 325 BLAKE2B b9d3bdc299f206991f900f0fefbf436445eedfd32b0c005919d37417003fb115d435924e424943554333fb65d6811d82e27436f6cd40b0818e204804da74ce6f SHA512 d7a0591bd66d48cab6821c9ac4131839a8b60f026ffbb677263f1af1a0f6f9b9dea2cfe3be003c40e2da7f16914ff2078ed591de0c6833406595010ed88479ff
diff --git a/dev-python/errorhandler/errorhandler-1.1.1-r2.ebuild b/dev-python/errorhandler/errorhandler-1.1.1-r2.ebuild
new file mode 100644
index 000000000000..98478dddd8c5
--- /dev/null
+++ b/dev-python/errorhandler/errorhandler-1.1.1-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Logging framework handler that tracks when messages above a certain level have been logged"
+HOMEPAGE="https://pypi.org/project/errorhandler/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="
+ dev-python/pkginfo[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-test.patch
+ "${FILESDIR}"/docs.patch
+)
+
+python_prepare_all() {
+ sed -e 's:../bin/sphinx-build:/usr/bin/sphinx-build:' -i docs/Makefile || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" -c "import errorhandler.tests as et, unittest; \
+ unittest.TextTestRunner().run(et.test_suite())" \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/errorhandler/files/docs.patch b/dev-python/errorhandler/files/docs.patch
new file mode 100644
index 000000000000..10c704d6fec3
--- /dev/null
+++ b/dev-python/errorhandler/files/docs.patch
@@ -0,0 +1,12 @@
+diff -ur errorhandler-1.1.1.orig/docs/conf.py errorhandler-1.1.1/docs/conf.py
+--- docs/conf.py 2009-11-07 20:08:10.000000000 +0800
++++ docs/conf.py 2013-06-07 14:05:17.321475285 +0800
+@@ -8,8 +8,6 @@
+ 'sphinx.ext.intersphinx'
+ ]
+
+-intersphinx_mapping = {'http://docs.python.org/dev': None}
+-
+ # General
+ source_suffix = '.txt'
+ master_doc = 'index'
diff --git a/dev-python/errorhandler/files/errorhandler-1.1.1-test.patch b/dev-python/errorhandler/files/errorhandler-1.1.1-test.patch
new file mode 100644
index 000000000000..126b508b9923
--- /dev/null
+++ b/dev-python/errorhandler/files/errorhandler-1.1.1-test.patch
@@ -0,0 +1,9 @@
+diff -ur errorhandler-1.1.1.orig/errorhandler/tests.py errorhandler-1.1.1/errorhandler/tests.py
+--- errorhandler/tests.py 2010-03-01 16:41:46.000000000 +0800
++++ errorhandler/tests.py 2012-04-26 02:28:11.991954681 +0800
+@@ -134,3 +134,5 @@
+ tearDown=tearDown,
+ optionflags=options),
+ ))
++if __name__ == "__main__":
++ unittest.main()
diff --git a/dev-python/errorhandler/metadata.xml b/dev-python/errorhandler/metadata.xml
new file mode 100644
index 000000000000..2fd7162096d2
--- /dev/null
+++ b/dev-python/errorhandler/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">errorhandler</remote-id>
+ </upstream>
+</pkgmetadata>