summaryrefslogtreecommitdiff
path: root/dev-python/eradicate/eradicate-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/eradicate/eradicate-2.0.0.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/eradicate/eradicate-2.0.0.ebuild')
-rw-r--r--dev-python/eradicate/eradicate-2.0.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/eradicate/eradicate-2.0.0.ebuild b/dev-python/eradicate/eradicate-2.0.0.ebuild
new file mode 100644
index 000000000000..ce8aeaeca5b2
--- /dev/null
+++ b/dev-python/eradicate/eradicate-2.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Removes commented-out code from Python files"
+HOMEPAGE="https://github.com/myint/eradicate"
+# TODO: revert to PyPI tarball once it includes tests
+# https://github.com/myint/eradicate/pull/28
+SRC_URI="https://github.com/myint/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest