summaryrefslogtreecommitdiff
path: root/dev-python/epsilon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/epsilon
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/epsilon')
-rw-r--r--dev-python/epsilon/Manifest6
-rw-r--r--dev-python/epsilon/epsilon-0.7.0.ebuild55
-rw-r--r--dev-python/epsilon/epsilon-0.7.1.ebuild59
-rw-r--r--dev-python/epsilon/files/epsilon_plugincache_portagesandbox.patch12
-rw-r--r--dev-python/epsilon/metadata.xml16
5 files changed, 148 insertions, 0 deletions
diff --git a/dev-python/epsilon/Manifest b/dev-python/epsilon/Manifest
new file mode 100644
index 000000000000..754b3a8909ca
--- /dev/null
+++ b/dev-python/epsilon/Manifest
@@ -0,0 +1,6 @@
+AUX epsilon_plugincache_portagesandbox.patch 537 BLAKE2B 44b8dbdb5069734f5cf12ed93518c332469fdab2c9793149effcab37b300eda9f2391f330fb5d7d1865a8bda80e488d1dfc17d7b81fefaa85b7d5fdbe1d50f21 SHA512 44aa8441d22951e573ddb6771f452c400bd971ae8cd17994959717c6d543d519bc9f2e0721e38815210048f553ca60fcc09260cd1fac1a4fc78c51055c7a6acc
+DIST Epsilon-0.7.0.tar.gz 81218 BLAKE2B c4cb4290087bb7d929dc793c190c26a0e90c1de89dc6c990dc3b53bd42499bc1979e7541bd8c416e15b10ff7478ff57b79896b88f6d1e72642dcfd20e1a9e488 SHA512 d1927ca431df3233a94296ca9e1f5dd70d6d61091d23f77df2222c6472d9a5f7b55c5c8dd2a75d0fead41af862c9e3a6a0ea9a31e21447459d5182f0d677d9b2
+DIST Epsilon-0.7.1.tar.gz 96820 BLAKE2B c856492f58e7e5ee35fdde51e876f7b4a93992e9cea556f5775d0017fc086fb7934ce9f892672331b8e363e9247bf8576a839d20fb7f5dea8f99b8c51bd5042d SHA512 ecf34a402208e514c430b4b3785df9b29f3708026ceba1301a2db8760b55111f59e7c40f868f4b642e4c7dd6c78735edbc32b2ef96ec3582e90aa2d978f06842
+EBUILD epsilon-0.7.0.ebuild 1707 BLAKE2B edaa1fcf5f51c5e8e5dfbca5686ab310b2d6ea5b2d13e12ff21d1b92c431f81f8a6e5da3d3a68cc13adc84be2ffa679a3eb893d3c5da04be8299f3c25b3f6fc4 SHA512 00498258f67ca64e52e195867b38178fcdb45bb075e3202467e2f057d0771e05b5d28ea496f872ddcdc078698c6c664d7768d89f8f6663235d64526768ab3fb4
+EBUILD epsilon-0.7.1.ebuild 1753 BLAKE2B fbb7738e6c069912b14d76cf4bf2b7c73a12d365c6897a8cb2aef687571250da6bb1c5a1eec5d3f29235c9c995ea290933a4958d593ef0f318e6e7940770205b SHA512 742770b1ca53c21034e429d5e801f3ece23f1eb5c1e36aac5b9250c8d8bca5f27ab351a10567f08e38f7e3f2eabf9f7aa5983c603b5f4fae652b679d93171f96
+MISC metadata.xml 652 BLAKE2B 595ad28125c6f7b0fb2ce56aea39a546e70f68a506b8a0e9708d930ac7fcba36ae15979c2e1745318655a755e3505c318043680cd3ca8f52f12fd2d9d5d063b2 SHA512 aad17bdfe9501dda95cf69d3b8069ec9dfe624a07c5f0ce4160cca62928217a16140a7188d87ffe46f0626624e25ae764db892170fad6f9f0bafff7dbb413d30
diff --git a/dev-python/epsilon/epsilon-0.7.0.ebuild b/dev-python/epsilon/epsilon-0.7.0.ebuild
new file mode 100644
index 000000000000..30a42d3d2844
--- /dev/null
+++ b/dev-python/epsilon/epsilon-0.7.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1 eutils
+
+DESCRIPTION="Epsilon is a Python utilities package, most famous for its Time class"
+HOMEPAGE="https://github.com/twisted/epsilon https://pypi.org/project/Epsilon/"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/twisted-core-13.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ ${DEPEND}"
+
+PATCHES=( "${FILESDIR}/epsilon_plugincache_portagesandbox.patch" )
+
+# epsilon doesn't install any plugins, so override the default
+TWISTED_PLUGINS=()
+
+python_prepare_all() {
+ # Rename to avoid file-collisions
+ mv bin/benchmark bin/epsilon-benchmark
+ sed -i \
+ -e "s#bin/benchmark#bin/epsilon-benchmark#" \
+ setup.py || die "sed failed"
+
+ #These test are removed upstream
+ rm -f epsilon/test/test_sslverify.py epsilon/sslverify.py || die
+ #See bug 357157 comment 5 for Ian Delaney's explanation of this fix
+ sed -e 's:month) 2004 9:month) 2004 14:' \
+ -i epsilon/test/test_extime.py || die
+ # Release tests need DivmodCombinator.
+ rm -f epsilon/test/test_release.py* epsilon/release.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ dodoc NAME.txt NEWS.txt
+
+ distutils-r1_python_install_all
+}
+
+#Lets run some tests, having prepped them
+python_test() {
+ # No testrunner seems stipulated within the source; pytest and nosetests both work
+ nosetests ${PN}/test || die "testsuite failed under ${EPYTHON}"
+}
diff --git a/dev-python/epsilon/epsilon-0.7.1.ebuild b/dev-python/epsilon/epsilon-0.7.1.ebuild
new file mode 100644
index 000000000000..110e0e768c54
--- /dev/null
+++ b/dev-python/epsilon/epsilon-0.7.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+DESCRIPTION="Epsilon is a Python utilities package, most famous for its Time class"
+HOMEPAGE="https://github.com/twisted/epsilon https://pypi.org/project/Epsilon/"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ || (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-13.2.0[${PYTHON_USEDEP}]
+ )
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ ${DEPEND}"
+
+PATCHES=( "${FILESDIR}/epsilon_plugincache_portagesandbox.patch" )
+
+# epsilon doesn't install any plugins, so override the default
+TWISTED_PLUGINS=()
+
+python_prepare_all() {
+ # Rename to avoid file-collisions
+ mv bin/benchmark bin/epsilon-benchmark
+ sed -i \
+ -e "s#bin/benchmark#bin/epsilon-benchmark#" \
+ setup.py || die "sed failed"
+
+ #These test are removed upstream
+ rm -f epsilon/test/test_sslverify.py epsilon/sslverify.py || die
+ #See bug 357157 comment 5 for Ian Delaney's explanation of this fix
+ sed -e 's:month) 2004 9:month) 2004 14:' \
+ -i epsilon/test/test_extime.py || die
+ # Release tests need DivmodCombinator.
+ rm -f epsilon/test/test_release.py* epsilon/release.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ dodoc NAME.txt NEWS.txt
+
+ distutils-r1_python_install_all
+}
+
+#Lets run some tests, having prepped them
+python_test() {
+ # No testrunner seems stipulated within the source; pytest and nosetests both work
+ nosetests ${PN}/test || die "testsuite failed under ${EPYTHON}"
+}
diff --git a/dev-python/epsilon/files/epsilon_plugincache_portagesandbox.patch b/dev-python/epsilon/files/epsilon_plugincache_portagesandbox.patch
new file mode 100644
index 000000000000..06bd55732011
--- /dev/null
+++ b/dev-python/epsilon/files/epsilon_plugincache_portagesandbox.patch
@@ -0,0 +1,12 @@
+--- epsilon/setuphelper.py.orig 2009-02-11 08:15:39.000000000 +0100
++++ epsilon/setuphelper.py 2009-02-11 08:18:56.000000000 +0100
+@@ -21,6 +21,9 @@
+ def _regeneratePluginCache(pluginPackages):
+ print 'Regenerating cache with path: ',
+ pprint.pprint(sys.path)
++ if os.getenv("PORTAGE_PLUGINCACHE_NOOP") != None:
++ print 'Not regenerating plugin cache for portage sandbox usage.'
++ return
+ from twisted import plugin
+ for pluginModule in pluginModules([
+ p + ".plugins" for p in pluginPackages]):
diff --git a/dev-python/epsilon/metadata.xml b/dev-python/epsilon/metadata.xml
new file mode 100644
index 000000000000..223df38b1fda
--- /dev/null
+++ b/dev-python/epsilon/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">A small utility package that depends on tools too recent for Twisted
+ (like datetime in python2.4) but performs generic enough functions
+ that it can be used in projects that don't want to share Divmod's
+ other projects' large footprint.</longdescription>
+ <upstream>
+ <remote-id type="pypi">Epsilon</remote-id>
+ <remote-id type="github">twisted/epsilon</remote-id>
+ </upstream>
+</pkgmetadata>