summaryrefslogtreecommitdiff
path: root/dev-python/enum34/enum34-1.1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/enum34/enum34-1.1.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/enum34/enum34-1.1.6.ebuild')
-rw-r--r--dev-python/enum34/enum34-1.1.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/enum34/enum34-1.1.6.ebuild b/dev-python/enum34/enum34-1.1.6.ebuild
new file mode 100644
index 000000000000..0223ef3faf92
--- /dev/null
+++ b/dev-python/enum34/enum34-1.1.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3.4 Enum backported"
+HOMEPAGE="https://pypi.python.org/pypi/enum34"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x86-macos ~x64-solaris"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" enum/test.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local DOCS=( enum/doc/. enum/README )
+
+ distutils-r1_python_install_all
+}