summaryrefslogtreecommitdiff
path: root/dev-python/entrypoints
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/entrypoints
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/entrypoints')
-rw-r--r--dev-python/entrypoints/Manifest5
-rw-r--r--dev-python/entrypoints/entrypoints-0.2.3.ebuild56
-rw-r--r--dev-python/entrypoints/files/entrypoints-0.2.1-init.py.patch8
-rw-r--r--dev-python/entrypoints/files/entrypoints-0.2.3-setup.py.patch20
-rw-r--r--dev-python/entrypoints/metadata.xml21
5 files changed, 0 insertions, 110 deletions
diff --git a/dev-python/entrypoints/Manifest b/dev-python/entrypoints/Manifest
deleted file mode 100644
index 07e1dc9f8337..000000000000
--- a/dev-python/entrypoints/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX entrypoints-0.2.1-init.py.patch 243 BLAKE2B 79706eacd51f9eb2b9bb319befc01c44894e2fa0c394585d2ad578b07e64fa4a6fce5e7c8f1c50752b1fa63e05776186759bc1ce426559405fd0a0e6c8b14aa3 SHA512 f25cb047aa8743dd9145c8e5913c53b5faa6a2b0ed3a50a957d69739bef43b3a6612ec38754bb088c2f9a8e116df61e00962fd1a78c45e5c107cbdd40a9569d0
-AUX entrypoints-0.2.3-setup.py.patch 614 BLAKE2B cd5248f366546bbba8c068d8a27f5853ced0757528f95f082473ab086dff5145f7735d48bb29da92237e1d1f31183726a0da4f7a8a405d1635c23ae634414c79 SHA512 eff2b655b0b0efe32fba265ee7816e6618062a665f86371104862cbc2e1ef79bd6ded749084ef18c09c6a5a43f572daff4c3377b6fa39b6b46d926de5bfeb42a
-DIST entrypoints-0.2.3.tar.gz 11219 BLAKE2B ae7745a075d564b3cc25a0580ae9f30f6e1a0b4bca7315c4fc3700408e4ab3762831212a451eb937ab94096d1db5c1478980b216dea7cfb95a8577d6337534a0 SHA512 dbf8085652e50cbdbe137ae655ef765cff58bdaa6beefebf1383dcd96dfcbf9c92580c09e9a58de7893aebdd7b2a701ef8d13a56ef0fa9a3d9ef7a5bd1d9b11b
-EBUILD entrypoints-0.2.3.ebuild 1292 BLAKE2B 8f2fbee1217b1a583326b1be65086a9a35b95fc07e745fa170eac34deefc013668c96f7522fffefc7e5f9416d991868f89a45a7ff60a75b754646e1e32736c10 SHA512 815fba7d01b70be7fd8521873802f172725e96ff982a9cda3686b0411c3af87b1291bf6304aca9075afec7b2b1351b97c22313baa70eb975094a93af542a65e0
-MISC metadata.xml 742 BLAKE2B 0d40b3569d09f83f28d5207a9667ea7029dce119d4fbebc474ee93191effe6c587b3e37423dc1deaa1a205089a6150a8c07d486487577b8078fa398ba411d90f SHA512 0588e7b73f038771ca8f1a6aa637f1d2a67ee1ea8bb35b73fcad109deaea11d7e57b61314a088c82d923de66e9fd8fc8ff5927dfc835ee587c819367f1f4d68d
diff --git a/dev-python/entrypoints/entrypoints-0.2.3.ebuild b/dev-python/entrypoints/entrypoints-0.2.3.ebuild
deleted file mode 100644
index 61878d994480..000000000000
--- a/dev-python/entrypoints/entrypoints-0.2.3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Discover and load entry points from installed packages"
-HOMEPAGE="https://github.com/takluyver/entrypoints"
-SRC_URI="https://github.com//takluyver/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="doc test"
-
-DEPEND="
- $(python_gen_cond_dep '>=dev-python/configparser-3.5.0[${PYTHON_USEDEP}]' 'python2*')
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- virtual/python-pathlib[${PYTHON_USEDEP}]
- )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- "
-
-PATCHES=(
- "${FILESDIR}/${P}"-setup.py.patch
- "${FILESDIR}/${PN}"-0.2.1-init.py.patch
-)
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-
- mv "${WORKDIR}/${P}"/entrypoints.py "${WORKDIR}/${P}/${PN}/" || die
-}
-
-python_compile_all() {
- if use doc; then
- emake -C doc html
- HTML_DOCS=( doc/_build/html/. )
- fi
-}
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}"/lib || die
- cp -r "${S}"/tests "${TEST_DIR}"/lib/ || die
- py.test || die
-}
diff --git a/dev-python/entrypoints/files/entrypoints-0.2.1-init.py.patch b/dev-python/entrypoints/files/entrypoints-0.2.1-init.py.patch
deleted file mode 100644
index 40d5d82730d3..000000000000
--- a/dev-python/entrypoints/files/entrypoints-0.2.1-init.py.patch
+++ /dev/null
@@ -1,8 +0,0 @@
-__init__.py for entrypoints by Marius Brehler <marbre@linux.sungazer.de>.
-
-Patch by Marius Brehler <marbrbre@linux.sungazer.de>.
---- /dev/null
-+++ b/entrypoints/__init__.py
-@@ -0,0 +1 @@
-+from .entrypoints import *
-\ No newline at end of file
diff --git a/dev-python/entrypoints/files/entrypoints-0.2.3-setup.py.patch b/dev-python/entrypoints/files/entrypoints-0.2.3-setup.py.patch
deleted file mode 100644
index 7ed226b489da..000000000000
--- a/dev-python/entrypoints/files/entrypoints-0.2.3-setup.py.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-setup.py for entrypoints by Marius Brehler <marbre@linux.sungazer.de>.
-
-Patch by Marius Brehler <marbrbre@linux.sungazer.de>.
---- /dev/null
-+++ b/setup.py
-@@ -0,0 +1,13 @@
-+from distutils.core import setup
-+
-+setup(name='entrypoints',
-+ version='0.2.3',
-+ description='Discover and load entry points from installed packages.',
-+ author='Thomas Kluyver',
-+ author_email='thomas@kluyver.me.uk',
-+ url='https://github.com/takluyver/entrypoints',
-+ packages=['entrypoints'],
-+ classifiers=[
-+ 'License :: OSI Approved :: MIT License'
-+ ]
-+)
-\ No newline at end of file
diff --git a/dev-python/entrypoints/metadata.xml b/dev-python/entrypoints/metadata.xml
deleted file mode 100644
index acbfe4f76fbe..000000000000
--- a/dev-python/entrypoints/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>marbre@linux.sungazer.de</email>
- <name>Marius Brehler</name>
- </maintainer>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription>
- Entry points are a way for Python packages to advertise objects with
- some common interface. The most common examples are console_scripts
- entry points, which define shell commands by identifying a Python
- function to run.
- </longdescription>
- <upstream>
- <remote-id type="github">takluyver/testpath</remote-id>
- </upstream>
-</pkgmetadata>