summaryrefslogtreecommitdiff
path: root/dev-python/ensurepip-pip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-15 02:26:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-15 02:26:52 +0100
commit152a6bc119e05c6c6da85b2fce57feb8c31d80b1 (patch)
tree92ba9f0b4c56acd5bbe6a9bcab07ca09fb62feb1 /dev-python/ensurepip-pip
parentd4be17a40855a064f44debc16c4ec9b501547a26 (diff)
gentoo auto-resync : 15:08:2022 - 02:26:52
Diffstat (limited to 'dev-python/ensurepip-pip')
-rw-r--r--dev-python/ensurepip-pip/Manifest3
-rw-r--r--dev-python/ensurepip-pip/ensurepip-pip-22.2.2.ebuild27
-rw-r--r--dev-python/ensurepip-pip/metadata.xml11
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/ensurepip-pip/Manifest b/dev-python/ensurepip-pip/Manifest
new file mode 100644
index 000000000000..117995bfcedb
--- /dev/null
+++ b/dev-python/ensurepip-pip/Manifest
@@ -0,0 +1,3 @@
+DIST pip-22.2.2-py3-none-any.whl 2044706 BLAKE2B 254427e593e44d9f1ce48276fd40f214e8ca9d27b6c31b7a6ed5fa4566df6b1f723215c6a1766a534ce18174f2363c383dbff19368d1b89f1519a53bebd34215 SHA512 142d3144c14b692c645613d98bf35dd91193128d5e21b61a8a702548f1247fac662499d6e39b65c0aa9a0444d2d92983fd8c410439796626485a4e1be99a102f
+EBUILD ensurepip-pip-22.2.2.ebuild 662 BLAKE2B 1addda7174ad9464d074dd238c3e70a3f2a2fda7b754fb79f461a1ad9dc2f03871ec98a2432374a3e336b64d4fa50dc48faa4c6922d6e792e759e73a895560d4 SHA512 779467e32d2a2ba759b1ae03a4d649c704ac666a57f980c3e0db33fe9493e4f546d39ff0cad43d7f00ffe87592cba20bca8b70515cc12cfbdff5e666714009a9
+MISC metadata.xml 309 BLAKE2B 197e5620aab85ff590270ae6838c9188cd699943af4c9c3eeb7de92c2e9390c082eec603e63bc2bba39477586f19e58da2e5fe2d5ffe9b59b87ae5386c939df1 SHA512 c678bc8fb62f6e6850939ebff56962503bb03393572cfff7e5f7d38e8cf5ca71d8e38e402355c5f963fb718eed24bca463d7c63fede5cbb550f6f32a9c06af9e
diff --git a/dev-python/ensurepip-pip/ensurepip-pip-22.2.2.ebuild b/dev-python/ensurepip-pip/ensurepip-pip-22.2.2.ebuild
new file mode 100644
index 000000000000..27ee812d0240
--- /dev/null
+++ b/dev-python/ensurepip-pip/ensurepip-pip-22.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN#ensurepip-}
+WHL=${MY_PN}-${PV}-py3-none-any.whl
+
+DESCRIPTION="Shared pip wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/pip/"
+SRC_URI="
+ https://files.pythonhosted.org/packages/py3/${MY_PN::1}/${MY_PN}/${WHL}
+"
+S=${DISTDIR}
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC LGPL-2.1+ MIT MPL-2.0 PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${WHL}"
+}
diff --git a/dev-python/ensurepip-pip/metadata.xml b/dev-python/ensurepip-pip/metadata.xml
new file mode 100644
index 000000000000..4bc0932869e1
--- /dev/null
+++ b/dev-python/ensurepip-pip/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pip</remote-id>
+ </upstream>
+</pkgmetadata>