summaryrefslogtreecommitdiff
path: root/dev-python/ensurepip-pip/ensurepip-pip-23.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-05 09:16:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-05 09:16:05 +0000
commita0c1504c093bc6abe04f9d96018f6252f81cd9ab (patch)
tree82e76cb195b40fe1b22aba9edf7048985b929f0d /dev-python/ensurepip-pip/ensurepip-pip-23.0.ebuild
parentc75fb751e4fd18ca8d87b0198e91a1976ffb2f2d (diff)
gentoo auto-resync : 05:02:2023 - 09:16:04
Diffstat (limited to 'dev-python/ensurepip-pip/ensurepip-pip-23.0.ebuild')
-rw-r--r--dev-python/ensurepip-pip/ensurepip-pip-23.0.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-python/ensurepip-pip/ensurepip-pip-23.0.ebuild b/dev-python/ensurepip-pip/ensurepip-pip-23.0.ebuild
index 971c00d30abe..8a4b916f03bd 100644
--- a/dev-python/ensurepip-pip/ensurepip-pip-23.0.ebuild
+++ b/dev-python/ensurepip-pip/ensurepip-pip-23.0.ebuild
@@ -3,14 +3,11 @@
EAPI=8
-MY_PN=${PN#ensurepip-}
-WHL=${MY_PN}-${PV}-py3-none-any.whl
+inherit pypi
DESCRIPTION="Shared pip wheel for ensurepip Python module"
HOMEPAGE="https://pypi.org/project/pip/"
-SRC_URI="
- https://files.pythonhosted.org/packages/py3/${MY_PN::1}/${MY_PN}/${WHL}
-"
+SRC_URI="$(pypi_wheel_url "${PN#ensurepip-}")"
S=${DISTDIR}
LICENSE="Apache-2.0 BSD BSD-2 ISC LGPL-2.1+ MIT MPL-2.0 PSF-2"
@@ -23,5 +20,5 @@ RDEPEND="
src_install() {
insinto /usr/lib/python/ensurepip
- doins "${WHL}"
+ doins "${A}"
}