summaryrefslogtreecommitdiff
path: root/dev-python/empy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/empy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/empy')
-rw-r--r--dev-python/empy/Manifest5
-rw-r--r--dev-python/empy/empy-3.3-r1.ebuild44
-rw-r--r--dev-python/empy/empy-3.3.2.ebuild39
-rw-r--r--dev-python/empy/metadata.xml8
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/empy/Manifest b/dev-python/empy/Manifest
new file mode 100644
index 000000000000..d62e0c93a781
--- /dev/null
+++ b/dev-python/empy/Manifest
@@ -0,0 +1,5 @@
+DIST empy-3.3.2.tar.gz 138168 BLAKE2B 0afbe6f7939898013770e18a0296d45a7a4121a3b8deb66a40b6fe37a311f9c4df1f864f4d975549cf4f198494f6f069d7ec186dfa5b99e19960b0c52a7aff2e SHA512 d9098823bbb26e4447aae9042e389e000f893615117512f9b786eedbc6875dee6b7f6be50021f68a4bd6e200b364852206b36bff5c48ae1754c8f0d49682d5f2
+DIST empy-3.3.tar.gz 137144 BLAKE2B 393f9033125459d6f3d5e9484d174980a00627508d083a32582f85eca9a294394ff028ee9df85ed73b8ff61174ae2068b0b943583fc86efa741bd2def63c215d SHA512 36304577839f5e6b2fb9bb2c2d72880e1f16886b2afadbcb38fd31a85620bb0369e837b8a1d74eab09a074bfe1f7be199b38842673106e0d26f1d9abc53987a7
+EBUILD empy-3.3-r1.ebuild 1136 BLAKE2B e31a65fac96c89e677c215af0dd7a139b8ebb8930252985d107261fa467d50e43f0743c52def437c60cc5600c1cc464206c9215a103135648208d219d1d297a2 SHA512 99a0cc0f4d40355769b00bb34af5f69e8c6eecc8dc653d55bd90202cf646c62e03c4e4207357f114b0d586ce9e27ac817c2fd5345687f14581c0e8b0bb882b84
+EBUILD empy-3.3.2.ebuild 1018 BLAKE2B 3ee8845ed0bd4bec8ddcf068d61793f8f6551cc19e44c7e5058dedb65c6e0a705126eb945b8dffb23fa641055488ee103449212e53e1a5d3bff949ec16c5b7e9 SHA512 773e801af6526febccd4432dae5a819ece6064decf7370281ee4f7716569822ff9475c750d370c6cc2e6d59120386536c7b52c773e58e2ddca42a05ea7cad991
+MISC metadata.xml 236 BLAKE2B 167eb58da19caba0e03167e2f209e118ce8a468851bca2790a0353112848fffcd72522497e5f951bf5c6eafa9691fa2a1ad980843cb4170a8194f3b8178ebe16 SHA512 0f2c2a0401b53543eac90eafdd4d11c5913be07f47b968e2892ca92c265adbd9564f02a491ff2607d7031194ba3e50c7720851537341b1541120821c487147a3
diff --git a/dev-python/empy/empy-3.3-r1.ebuild b/dev-python/empy/empy-3.3-r1.ebuild
new file mode 100644
index 000000000000..9cab539714f7
--- /dev/null
+++ b/dev-python/empy/empy-3.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful and robust templating system for Python"
+HOMEPAGE="http://www.alcyone.com/software/empy/"
+SRC_URI="http://www.alcyone.com/software/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ia64 ppc x86"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+python_prepare_all() {
+ sed -e "s:/usr/local/bin/python:/usr/bin/python:g" -i em.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" em.py sample.em | diff sample.bench -
+ if [[ ${PIPESTATUS[0]} -ne 0 || ${PIPESTATUS[1]} -ne 0 ]]; then
+ die "Testing failed with ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use doc; then
+ dodir /usr/share/doc/"${PF}"/examples
+ insinto /usr/share/doc/"${PF}"/examples
+ doins sample.em sample.bench
+ #3.3 has the html in this funny place. Fix in later version:
+ dohtml doc/home/max/projects/empy/doc/em/*
+ dohtml doc/home/max/projects/empy/doc/em.html
+ dohtml doc/index.html
+ fi
+}
diff --git a/dev-python/empy/empy-3.3.2.ebuild b/dev-python/empy/empy-3.3.2.ebuild
new file mode 100644
index 000000000000..5627436175d2
--- /dev/null
+++ b/dev-python/empy/empy-3.3.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful and robust templating system for Python"
+HOMEPAGE="http://www.alcyone.com/software/empy/"
+SRC_URI="http://www.alcyone.com/software/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" em.py sample.em | diff sample.bench -
+ if [[ ${PIPESTATUS[0]} -ne 0 || ${PIPESTATUS[1]} -ne 0 ]]; then
+ die "Testing failed with ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use doc; then
+ dodir /usr/share/doc/"${PF}"/examples
+ insinto /usr/share/doc/"${PF}"/examples
+ doins sample.em sample.bench
+ #3.3 has the html in this funny place. Fix in later version:
+ dohtml doc/home/max/projects/empy/doc/em/*
+ dohtml doc/home/max/projects/empy/doc/em.html
+ dohtml doc/index.html
+ fi
+}
diff --git a/dev-python/empy/metadata.xml b/dev-python/empy/metadata.xml
new file mode 100644
index 000000000000..9e5274c5b4ae
--- /dev/null
+++ b/dev-python/empy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+</pkgmetadata>