summaryrefslogtreecommitdiff
path: root/dev-python/empy/empy-3.3.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/empy/empy-3.3.4-r1.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/empy/empy-3.3.4-r1.ebuild')
-rw-r--r--dev-python/empy/empy-3.3.4-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/empy/empy-3.3.4-r1.ebuild b/dev-python/empy/empy-3.3.4-r1.ebuild
new file mode 100644
index 000000000000..93a4db847ee6
--- /dev/null
+++ b/dev-python/empy/empy-3.3.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful and robust templating system for Python"
+HOMEPAGE="http://www.alcyone.com/software/empy/"
+SRC_URI="http://www.alcyone.com/software/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="doc"
+
+python_test() {
+ "${PYTHON}" em.py sample.em | diff sample.bench -
+ assert "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ docinto examples
+ dodoc sample.em sample.bench
+ # 3.3 has the html in this funny place. Fix in later version:
+ docinto html
+ dodoc doc/home/max/projects/empy/doc/em/*
+ dodoc doc/home/max/projects/empy/doc/em.html
+ dodoc doc/index.html
+ fi
+}