summaryrefslogtreecommitdiff
path: root/dev-python/emcee/emcee-2.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/emcee/emcee-2.2.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/emcee/emcee-2.2.1.ebuild')
-rw-r--r--dev-python/emcee/emcee-2.2.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/emcee/emcee-2.2.1.ebuild b/dev-python/emcee/emcee-2.2.1.ebuild
new file mode 100644
index 000000000000..7c6cce8b9fd5
--- /dev/null
+++ b/dev-python/emcee/emcee-2.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python ensemble sampling toolkit for affine-invariant MCMC"
+HOMEPAGE="http://danfm.ca/emcee/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+DOCS=( AUTHORS.rst README.rst )
+
+python_test() {
+ nosetests -v || die
+}