summaryrefslogtreecommitdiff
path: root/dev-python/elementpath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-22 06:30:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-22 06:30:44 +0000
commit5a2cecfc8661e1d3a762adf05cf8eb142cd41710 (patch)
tree341806a72603cc8845e7e1595289e7a8b9570f2a /dev-python/elementpath
parentd2bcdab82e5f5f38a8ab54026e8aa94edb1b77a6 (diff)
gentoo auto-resync : 22:12:2024 - 06:30:44HEADmaster
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/Manifest2
-rw-r--r--dev-python/elementpath/elementpath-4.7.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index 385bc22db553..363fc9c6e756 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1,3 +1,5 @@
DIST elementpath-4.6.0.tar.gz 355931 BLAKE2B 7617e778bb48b3d7aaf9ec4043af3827c2bd41eb3b0f7a2e4dae71d080cacd9d9a7932f8d358dc8d1fbd2e872fe9f390b90be4a55e04030eba806183e2d29fc1 SHA512 87e01f2aa2c98b626a1cfa38b4695c16b39c1425dbe686afef092cb265b82e6dc25997c989ffa2b198a6cb60e042d2361fabb0b53fb3efb853263a5651a59fd6
+DIST elementpath-4.7.0.tar.gz 357225 BLAKE2B 4f39f27ff6be7ae3b159b1a8c6bbba30dcb2cd4306df0f61c0ec8895faf382a19aed23dd10552224b64b91f99b0efbeaba22901b8ab920ec9f1074472d1a3f47 SHA512 320b7d037247412604be5365d60a8fb9040f2c29b36484d8b8a6894647aad6ba2f903d29d9c2fcbe25de1e075bdc2a879bfdd72b8443481030df6dcebd152e6f
EBUILD elementpath-4.6.0.ebuild 758 BLAKE2B dd119799c7fda21932a0bcdcf67727fd319f43e987058bfaec2f80ba8c5b26a44e57ee349ce53909d84ffdfe7d42487310228d06c81ae81f2c3c8cfd456feeca SHA512 92512ab6f01c8154b313c6dffc53482ab7b4a9cbfe96596064d24a09ecef6c1be4f1559e3e05a4d5f676a9b989358423cd573c44d9d3c2345388b77534fe0a2d
+EBUILD elementpath-4.7.0.ebuild 766 BLAKE2B dc9b2ed18736343dcd818380e2ea0f271a8619898d180980c5922e0699bd82f4e26559ed14ba693acb268b0b7dd4657262dea4037007d6385d10a79c19d82045 SHA512 e74f1722b1e1b925877aeb3a16637d12a0c81b2ce6c0f362a22bcc8edae47ae6aafb402065ebcd3c69b85af4c7696c50e41c0c546baa584653f4230f4b2befd6
MISC metadata.xml 380 BLAKE2B 00a18a4c9373b73866c8f5159e6c11327baea8ea6ba8027c2477cefaf6bbd2d2838de3cf78b9bc3e8bdffd0444e6c44b45cf6e6aac0f7ac470c7e092ae4e43f9 SHA512 abdc862e0d684023fcd42843a9c558d71e923a09fb0592e5e3c3e7e949e311c36afc34ee3cea5873c1799b093924fe15c240da4a782fdbca11ace66ea0d2717c
diff --git a/dev-python/elementpath/elementpath-4.7.0.ebuild b/dev-python/elementpath/elementpath-4.7.0.ebuild
new file mode 100644
index 000000000000..a45ac427b816
--- /dev/null
+++ b/dev-python/elementpath/elementpath-4.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="
+ https://github.com/sissaschool/elementpath/
+ https://pypi.org/project/elementpath/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/xmlschema-3.3.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # fails for some reason, more fit for upstream testing anyway
+ tests/test_typing.py
+)