summaryrefslogtreecommitdiff
path: root/dev-python/elementpath/elementpath-4.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-27 07:34:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-27 07:34:25 +0100
commit61faa1ea0e8302df305bc281038fc00dc7eb1dd4 (patch)
tree80638756ce07f0db3bcdc33653970fa5452df743 /dev-python/elementpath/elementpath-4.1.4.ebuild
parent00757bf15f0eb42661625ed16888d00af9a79561 (diff)
gentoo auto-resync : 27:06:2023 - 07:34:25
Diffstat (limited to 'dev-python/elementpath/elementpath-4.1.4.ebuild')
-rw-r--r--dev-python/elementpath/elementpath-4.1.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/elementpath/elementpath-4.1.4.ebuild b/dev-python/elementpath/elementpath-4.1.4.ebuild
new file mode 100644
index 000000000000..5a131dfbbd75
--- /dev/null
+++ b/dev-python/elementpath/elementpath-4.1.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="
+ https://github.com/sissaschool/elementpath/
+ https://pypi.org/project/elementpath/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # fails for some reason, more fit for upstream testing anyway
+ rm tests/test_typing.py || die
+ distutils-r1_src_prepare
+}