summaryrefslogtreecommitdiff
path: root/dev-python/elementpath/elementpath-2.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-17 17:57:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-17 17:57:35 +0100
commit7932d472a02d4c016ff7dff4b7a5479ab9d1883d (patch)
treed07709230f82777cae6ba7dab35aee31896060fb /dev-python/elementpath/elementpath-2.2.3.ebuild
parentd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (diff)
gentoo resync : 17.06.2021
Diffstat (limited to 'dev-python/elementpath/elementpath-2.2.3.ebuild')
-rw-r--r--dev-python/elementpath/elementpath-2.2.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/elementpath/elementpath-2.2.3.ebuild b/dev-python/elementpath/elementpath-2.2.3.ebuild
new file mode 100644
index 000000000000..d8a77de4b139
--- /dev/null
+++ b/dev-python/elementpath/elementpath-2.2.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="https://github.com/sissaschool/elementpath/
+ https://pypi.org/project/elementpath/"
+SRC_URI="
+ https://github.com/sissaschool/elementpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest