summaryrefslogtreecommitdiff
path: root/dev-python/elasticsearch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-14 11:06:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-14 11:06:13 +0100
commite000645bea7492c9f5277722c0ada7e1ee0b4833 (patch)
treea604499d25e682002ec55cc5e7d14e0c53809199 /dev-python/elasticsearch
parentbe8708090362c01c6111c4b76f1e395c14d86e00 (diff)
gentoo auto-resync : 14:08:2024 - 11:06:13
Diffstat (limited to 'dev-python/elasticsearch')
-rw-r--r--dev-python/elasticsearch/Manifest2
-rw-r--r--dev-python/elasticsearch/elasticsearch-8.15.0.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/elasticsearch/Manifest b/dev-python/elasticsearch/Manifest
index d5c915398029..4586dd2c3bad 100644
--- a/dev-python/elasticsearch/Manifest
+++ b/dev-python/elasticsearch/Manifest
@@ -1,3 +1,5 @@
DIST elasticsearch-py-8.14.0.gh.tar.gz 1092912 BLAKE2B 4ee556bc475d63e33cec318936b2dbf8b280236bcdfe28bc90a4beb7e1d024b8d63180c29e42096cb32bf3da7c771532c57190d763651118603779f816e95656 SHA512 9e9821102659b4c877959e25c33e1b1942f6eabe62bb6de73cda4875c248b0f9285d948e535e9426ca42552f7aa3e75c459f991bfa574c1d8400d78486ee5493
+DIST elasticsearch-py-8.15.0.gh.tar.gz 1163528 BLAKE2B 8ee26e504f09b4ed2ccd695c034f5e35bdc609c1de7055b1f93f279edc7b3b6ac72625e8645c25d126481d7d877a197ecb8d7b35771841b412291caa42d4ee5f SHA512 7982f8366d7b74c85fdcaf4761fcbd9e6e14f0ef2a4aff353bad0b5bbedf7251eabf933e86f1dc9734de0aa6d43a30e1f055cd3b9c7ff2c7864da8779f64bfbc
EBUILD elasticsearch-8.14.0.ebuild 2467 BLAKE2B 71f500c6a0e7d9f629e89ccea51ff7861693eb92b0fd61e8582854496b299ab04d635e5838a10f448d0c21cb466556205f7e717e9ccf96d8d3de1e4216df9e27 SHA512 43964923af4a88cf471b70a07bc0103c16fa9b6717fe1ace5854c34de56074a34a4f377adc02571178a43d57055f5c383b6ab0cc1bd3f6a96b1963b71f33c4fd
+EBUILD elasticsearch-8.15.0.ebuild 2303 BLAKE2B 9eb7fe67cfc592f89378e46e7aaa152b09f50b4f602f41f2dfe9e792d575b4c317da230d242be1b13d5695035e42cb1e1a8b77d0999314f890a548a3d25929e3 SHA512 32c4085f8089eed96fb96c9e34483bcd24bb4385275ac1d58d6117f1f0baa18c4862dae25f7fdd6e2fdc76e63b2529dc33f3a32e2d5d4816217ebac9b81ab4b9
MISC metadata.xml 617 BLAKE2B f87827e173c4284a6ac830c48f92384140ad388a1c35562e5522ffc7fa654a9fc1eca14fd55b4365aec7ecbe1ca54f1a58772e240f09c3a56aaf25114b807cae SHA512 dc52446e828b8506e5144fb77e2bf5f761afeed8dda67c1aa72f0f67a3df838712d3deceba12c434b2d53923130e55ba6a71086ec289d90d5577cb5950b46999
diff --git a/dev-python/elasticsearch/elasticsearch-8.15.0.ebuild b/dev-python/elasticsearch/elasticsearch-8.15.0.ebuild
new file mode 100644
index 000000000000..741cff10115f
--- /dev/null
+++ b/dev-python/elasticsearch/elasticsearch-8.15.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+MY_P="elasticsearch-py-${PV}"
+DESCRIPTION="Official Elasticsearch client library for Python"
+HOMEPAGE="
+ https://ela.st/es-python
+ https://github.com/elastic/elasticsearch-py/
+ https://pypi.org/project/elasticsearch/
+"
+SRC_URI="
+ https://github.com/elastic/elasticsearch-py/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/aiohttp-4[${PYTHON_USEDEP}]
+ >=dev-python/aiohttp-3[${PYTHON_USEDEP}]
+ <dev-python/elastic-transport-9[${PYTHON_USEDEP}]
+ >=dev-python/elastic-transport-8.13[${PYTHON_USEDEP}]
+ >=dev-python/orjson-3[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mapbox-vector-tile[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/opentelemetry-api[${PYTHON_USEDEP}]
+ dev-python/opentelemetry-sdk[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pyarrow[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ dev-python/unasync[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/sphinx \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # REST api tests are a black hole for effort. It downloads the tests
+ # so its an ever moving target. It also requires effort to blacklist
+ # tests for apis which are license restricted.
+ "test_elasticsearch/test_server/test_rest_api_spec.py"
+ # Counting deprecation warnings from python is bound to fail even
+ # if all are fixed in this package. Not worth it.
+ "test_elasticsearch/test_client/test_deprecated_options.py"
+ # Running daemon for tests is finicky and upstream CI fails at it
+ # as well.
+ "test_elasticsearch/test_server/"
+ "test_elasticsearch/test_async/test_server/"
+ )
+
+ local -x TEST_WITH_OTEL=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -p asyncio
+}