summaryrefslogtreecommitdiff
path: root/dev-python/elasticsearch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-09 11:11:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-09 11:11:11 +0000
commit90a73bb153519a9eac2a23eb9029b99b759e7892 (patch)
tree6d01f49a1e594c9324241c03aac67a635f828834 /dev-python/elasticsearch
parentf6f5cf314dddfbfe0f8c848dc9e07436b032562c (diff)
gentoo auto-resync : 09:12:2023 - 11:11:11
Diffstat (limited to 'dev-python/elasticsearch')
-rw-r--r--dev-python/elasticsearch/Manifest2
-rw-r--r--dev-python/elasticsearch/elasticsearch-8.11.1.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/elasticsearch/Manifest b/dev-python/elasticsearch/Manifest
index 64ce434b8aa9..1003e7c5979a 100644
--- a/dev-python/elasticsearch/Manifest
+++ b/dev-python/elasticsearch/Manifest
@@ -1,3 +1,5 @@
DIST elasticsearch-py-8.11.0.gh.tar.gz 897889 BLAKE2B de1821f17c16198c8b85b863e06468715fb080b4e9354499bd4fc5c485dc81bb3747ee73bd5e26edcab71922d67699cbaba79b35a900b80020532bac805e5727 SHA512 914e909f5f2d6ee980d3cff981d1d605d9380211014381e9e998af46d52e0fc0568524c7c9e8d8fed710b855acdb15b1eeb0bcdb59607b67f2f8f99546a1bda8
+DIST elasticsearch-py-8.11.1.gh.tar.gz 902628 BLAKE2B 7a1d780ff9f326567b4023f4a87b2a3be430428c00c528d255502d36623b7d1d6e0811f50a03471254eb79fb1e4146ad24402f202c862cafb44ec16fbcdb454f SHA512 e2efbd3e0658180768a35b601e7bef2748390ce12419f82cdfb1656968666fcc6ae71411d4e88eb155b315d8d8197f65c3e25e6f1e18f04e6459662cf80ab12a
EBUILD elasticsearch-8.11.0.ebuild 2075 BLAKE2B 14ed493b4df750127118b0d1632ce3e755e58ff12f4f33395786b6822d163ab3c844f003d55b55635b8f7f57f6d87d0f963179bda8fc444a42ef8db364614ec2 SHA512 da36f77e4556c5e5e900a3e0ac1165e2c11a385f60aed20c1056876a7c8a512bf2efc22fabe9606ce1df7479714d32ff11739fbab680a6474dce0c210a46a5d7
+EBUILD elasticsearch-8.11.1.ebuild 2077 BLAKE2B 45ac7ef522aa8927d41126ead24091a8ceb2c3275cc349ca6911a690b0569343505cf3a629c45ca19113628539c32b206b0291452de4cabd6e4a2d64c217f91a SHA512 9b46844dcd2fc13fe40e3e501199207ff36d651f5113bd74d043694c16d61738d4437d9f3977801395901ce2bedcca247733b164a009a358bddc00b29655377a
MISC metadata.xml 563 BLAKE2B 55aa4f1e346ef660c4c8c5bf53518685e68fea80787d4a4175405e67c2b6e9c31d14fd48577c48c82ed59651c32110d4dbbd907ce29b599ca3bddddd1b5e808a SHA512 142657aca39d615755acb7cd6bdaa920935640ce1e3f00a241bb2a41ce2745fd73e341b80edf3fd830e9c9796285df1d69e62b868252602b6ff9e1ff6a2be599
diff --git a/dev-python/elasticsearch/elasticsearch-8.11.1.ebuild b/dev-python/elasticsearch/elasticsearch-8.11.1.ebuild
new file mode 100644
index 000000000000..59a9b7acf2e5
--- /dev/null
+++ b/dev-python/elasticsearch/elasticsearch-8.11.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="elasticsearch-py-${PV}"
+DESCRIPTION="Official Elasticsearch client library for Python"
+HOMEPAGE="
+ https://ela.st/es-python
+ https://github.com/elastic/elasticsearch-py/
+ https://pypi.org/project/elasticsearch/
+"
+SRC_URI="
+ https://github.com/elastic/elasticsearch-py/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/aiohttp-4[${PYTHON_USEDEP}]
+ >=dev-python/aiohttp-3[${PYTHON_USEDEP}]
+ <dev-python/elastic-transport-9[${PYTHON_USEDEP}]
+ >=dev-python/elastic-transport-8[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mapbox-vector-tile[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ dev-python/unasync[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # REST api tests are a black hole for effort. It downloads the tests
+ # so its an ever moving target. It also requires effort to blacklist
+ # tests for apis which are license restricted.
+ "test_elasticsearch/test_server/test_rest_api_spec.py"
+ # Counting deprecation warnings from python is bound to fail even
+ # if all are fixed in this package. Not worth it.
+ "test_elasticsearch/test_client/test_deprecated_options.py"
+ # Running daemon for tests is finicky and upstream CI fails at it
+ # as well.
+ "test_elasticsearch/test_server/"
+ "test_elasticsearch/test_async/test_server/"
+)
+
+distutils_enable_sphinx docs/sphinx \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -p asyncio
+}