summaryrefslogtreecommitdiff
path: root/dev-python/ed25519ll/ed25519ll-0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/ed25519ll/ed25519ll-0.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/ed25519ll/ed25519ll-0.6.ebuild')
-rw-r--r--dev-python/ed25519ll/ed25519ll-0.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/ed25519ll/ed25519ll-0.6.ebuild b/dev-python/ed25519ll/ed25519ll-0.6.ebuild
new file mode 100644
index 000000000000..62a6fb63c32a
--- /dev/null
+++ b/dev-python/ed25519ll/ed25519ll-0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A low-level ctypes wrapper for Ed25519 digital signatures."
+HOMEPAGE="http://bitbucket.org/dholth/ed25519ll/ http://pypi.python.org/pypi/ed25519ll"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+# https://bitbucket.org/dholth/ed25519ll/issues/1/testfailures-with-python-3
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}