summaryrefslogtreecommitdiff
path: root/dev-python/ecdsa/ecdsa-0.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/ecdsa/ecdsa-0.13.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/ecdsa/ecdsa-0.13.ebuild')
-rw-r--r--dev-python/ecdsa/ecdsa-0.13.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/ecdsa/ecdsa-0.13.ebuild b/dev-python/ecdsa/ecdsa-0.13.ebuild
new file mode 100644
index 000000000000..231b94165cd8
--- /dev/null
+++ b/dev-python/ecdsa/ecdsa-0.13.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ECDSA cryptographic signature library in pure Python"
+HOMEPAGE="https://github.com/warner/python-ecdsa"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}