summaryrefslogtreecommitdiff
path: root/dev-python/dulwich
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-30 09:03:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-10-30 09:03:01 +0000
commita41f630aea0b4b71a6c9a088571f1eaaf8413d53 (patch)
tree2434c552b001d6b577a10a50bea2dd828676f27d /dev-python/dulwich
parentb77e1a6cc7c668e135d139c5ec5ad0ae1c11b857 (diff)
gentoo auto-resync : 30:10:2022 - 09:03:01
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/Manifest2
-rw-r--r--dev-python/dulwich/dulwich-0.20.50.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index d537eabb05e4..38e324f909e5 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1,3 +1,5 @@
DIST dulwich-0.20.46.tar.gz 426530 BLAKE2B 702564597a0367f454a396e4917d4fcd8b963d1847ddef688dccc7d7501f0073ae9a0ab422f31b8b0648210dafa953744ccf496b41fc75c7bea5090d75bf142c SHA512 4cc86afe90139d813d11ac2a8b96e84ca60ea28baab83a2af8da9a7cef2f3cdac647af858f5fc3806ae741a0b4fcf592d94f228adf8ab7b5b600be41f6acc356
+DIST dulwich-0.20.50.tar.gz 430389 BLAKE2B 1ea86fe00fa560311bdcff8c51904982a506fa670efb503f9103c5fb25036a792a87583fdf6435a6a6ec7bd6aaa2277c621359e1d99f55450c247fdc4be74e51 SHA512 506cc76f7deb8247b910fa4971e28eeda6ddd34703ac3c7a2f3b6525e6a9229bbec527b1965bebf7aa3da17b5adbd146916f247acacf9caf86d2494e60cc8626
EBUILD dulwich-0.20.46.ebuild 1644 BLAKE2B c27c433faf91999c3a52391cde1bd690c19edaf77b12f5b7fbccb9c5c9c52f2cd7ff0bb1ee162991738ff46d8ab892b10d4590c3b2f6f0aa653b04a2dcbfdd0a SHA512 bd78b84c26d625706bffcecd4fa3cb187746392df0366f4107262628034dbbe7095ea9a54fc9d826acaa8ce315c7c5ec33d62a5b7c2e85d58c77d75504caeea6
+EBUILD dulwich-0.20.50.ebuild 1648 BLAKE2B a84255d92600ace910828a4db9c1ec73fc194f8cdf4e0ae4a73f60c41a090cc24c425345270f43b1a8cfb5463ad5733c43b6e044524b993373ae417e22baa9f6 SHA512 3ebe2c5e59d6e64cff08362840609579c6ab1e64d52ff8eb38edb8c3cad2cfb973ebcd33526fcc6d425acf57f3816a9079ca90e4b91bce0f2d2a1d0251d3a654
MISC metadata.xml 556 BLAKE2B 240554ff522160e9508bf6debadafcc44b5ccc4074dd4c9d3ce82358963084c60a1afae9fafee6ab1e6e5d898940ccb4d1b524cebff155e61bf6707c9396b647 SHA512 a7cdca224a01d5bd26bf4a5adb0273977ddff61f75cd02f5642132656fd0c6608114617efcb068d834f107804666cf4fb3725967e804b73d2ddcb67342dc30de
diff --git a/dev-python/dulwich/dulwich-0.20.50.ebuild b/dev-python/dulwich/dulwich-0.20.50.ebuild
new file mode 100644
index 000000000000..afced5638714
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.20.50.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="
+ https://github.com/jelmer/dulwich/
+ https://pypi.org/project/dulwich/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+ Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ !hppa? ( !ia64? ( !s390? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/geventhttpclient[${PYTHON_USEDEP}]
+ ) ) )
+ app-crypt/gpgme[python,${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/fastimport[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ # remove interference from the tests that do stuff like user.name
+ unset GIT_AUTHOR_NAME GIT_AUTHOR_EMAIL GIT_AUTHOR_DATE \
+ GIT_COMMITTER_NAME GIT_COMMITTER_EMAIL GIT_COMMITTER_DATE EMAIL
+ # Do not use make check which rebuilds the extension and uses -Werror,
+ # causing unexpected failures.
+ "${EPYTHON}" -m unittest -v dulwich.tests.test_suite ||
+ die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}