summaryrefslogtreecommitdiff
path: root/dev-python/dulwich
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-25 12:50:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-25 12:50:15 +0000
commit71d582d27eeece574ab3d904aa3fbe7742b0e895 (patch)
treea859a9d4a94b41c113fb5bdb5c4ffe261d884970 /dev-python/dulwich
parent0b82ae29b3034efe3e7b7f533dbcb76168544c5e (diff)
gentoo auto-resync : 25:03:2023 - 12:50:15
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/Manifest2
-rw-r--r--dev-python/dulwich/dulwich-0.21.2.ebuild55
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index 3a34aef154fb..effc7a970ab3 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1,5 +1,3 @@
-DIST dulwich-0.21.2.tar.gz 436949 BLAKE2B 8c3b42e103146c3641292eaaae29b2e53690a84fe0ba68adcaecc7ed75ce5ee3af64cffcc702b98a5bef18b6edfe888b2db0232430cf0289d1ca14dd49f3fb14 SHA512 edc7ea98f3417bd3f460d3c5fb54ceb1974df79e85fea4b4d324a79f487a5303edbdb256bae0b5c6e83615cf8788a2a921bfbd5031d4d3e4dbdd1c97ea1295e8
DIST dulwich-0.21.3.tar.gz 437815 BLAKE2B 889bb20800bbf45da6ddd688ed1e8ff2ca76fc3671409bb4bee4ed7604f008610adcd68feda9bf50bdd6432d3ad400e381506369d6411905a8388884093d5540 SHA512 ffe89535bd48709e68bff6b299034ab6ccd28960cc32b3717d9779c84c87548d8366dfadfb0699c99b99f8e599d91284e05dcc3c1f9ae4d7b208500856eb33ac
-EBUILD dulwich-0.21.2.ebuild 1519 BLAKE2B 8a60db99c5074d493c79d9716f3ff59c3a4a58e705689d8accfa990e3bdeeb7c11ecd2d54d9a9012540c706dd7b13076ef9a339393e2c9c7056f4f43dacc42b7 SHA512 db8f6cab8b4604a2b174dbbfec5e107752aa00da05d0a1f6caba2a6b50cccb3fa0ef66a5239d4f21a04fc574643c003b1d1c99f35c825f53deaffe98986d0159
EBUILD dulwich-0.21.3.ebuild 1472 BLAKE2B 649c51be32d4498bf160138bdd7928c856c6f313bb6491e8ed3346046c13fc225f515396fdb17321e0ece37112e805ab7d93370652d0abbaf1de018ee3e6f22c SHA512 315aeead4f458df8c70a3c7468a2fa71d1a5a79febbc3146bc6fd5d4f388cad4a1638bbe87770702f06dfe5ca134a109604e154e9413dd6b0740a7ace9031b1b
MISC metadata.xml 556 BLAKE2B 240554ff522160e9508bf6debadafcc44b5ccc4074dd4c9d3ce82358963084c60a1afae9fafee6ab1e6e5d898940ccb4d1b524cebff155e61bf6707c9396b647 SHA512 a7cdca224a01d5bd26bf4a5adb0273977ddff61f75cd02f5642132656fd0c6608114617efcb068d834f107804666cf4fb3725967e804b73d2ddcb67342dc30de
diff --git a/dev-python/dulwich/dulwich-0.21.2.ebuild b/dev-python/dulwich/dulwich-0.21.2.ebuild
deleted file mode 100644
index d774e8bcb728..000000000000
--- a/dev-python/dulwich/dulwich-0.21.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
-HOMEPAGE="
- https://github.com/jelmer/dulwich/
- https://pypi.org/project/dulwich/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2+ Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ppc ~ppc64 ~riscv ~s390 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- app-crypt/gpgme[python,${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/fastimport[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs
-
-python_test() {
- # remove interference from the tests that do stuff like user.name
- unset GIT_AUTHOR_NAME GIT_AUTHOR_EMAIL GIT_AUTHOR_DATE \
- GIT_COMMITTER_NAME GIT_COMMITTER_EMAIL GIT_COMMITTER_DATE EMAIL
- # Do not use make check which rebuilds the extension and uses -Werror,
- # causing unexpected failures.
- "${EPYTHON}" -m unittest -v dulwich.tests.test_suite ||
- die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- dodoc -r examples
- fi
- distutils-r1_python_install_all
-}