summaryrefslogtreecommitdiff
path: root/dev-python/dulwich
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /dev-python/dulwich
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/Manifest4
-rw-r--r--dev-python/dulwich/dulwich-0.20.15.ebuild56
-rw-r--r--dev-python/dulwich/metadata.xml8
3 files changed, 65 insertions, 3 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index 96e6f1b1a1bd..4c7452684151 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1,3 +1,5 @@
+DIST dulwich-0.20.15.tar.gz 391841 BLAKE2B 8db19f84154dff0851fd16bc534d92b506c93a93d7180079bc9829a2c81bbb25b04b234770e62ddab82440973d0702b8523896a9db90d771d8cc915b6321cdaa SHA512 a4e746099a90ea2d7eb5f0309508a4f625d41732bdda78997fab07b38ea2ecbd2c2aed08c8ef05b1b73fe3e2ba9b8c8cbf02270f8edbc6235d66cdee0317365c
DIST dulwich-0.20.6.tar.gz 388660 BLAKE2B 1a193d03e0f21a9fdd125617823742b87e9bea74c73734da10eb79f1ecbec0263cb90224f78413c724db8998f4d06ff6c448e7a6d50ce760ba1545f3321b95d8 SHA512 2f11ce9a1c716fb4242f1f93fce92f756bd93ed8f0951fc2e6b3fb18b0a495b0f372966149fca587efcafc0eaf00e9fbfcfd957442a96cc2004eb66cb7f0773e
+EBUILD dulwich-0.20.15.ebuild 1637 BLAKE2B 681814a1075f26afc3f9248fa885c761e98980925e974a5accc2ff0cb5d21e82800ab934f7d0fabdd7d105865bf3465b166450fbf092cbaadf5679bd6f7ace97 SHA512 469a34d683a5b60c9dc4605dff47acfbb1e75b296619f792a895e4e1a8cd23ba0d06b1fc27d25a8d95213442ebd1d5a712cc69e0b6cecd7c894e043c0b9a4b28
EBUILD dulwich-0.20.6.ebuild 1629 BLAKE2B 442f1ae67267b89da34bfac860ae2fab0f04e8d255fe584e63fef042fd5b234f22e2179fb09c5095223dd73e9c8f534e049d48845125879c52bfae86d5eb7d00 SHA512 f84e91a012104d467a226e99a00d00db6e831dd0770952e0b4c5f77219c3b65f4b7cc709f21ef35d7b7bd095875d114185f1663bf7ac43d7a1c3b331a9c46525
-MISC metadata.xml 448 BLAKE2B 15b62d6a9a252067a63c02db94a906b0da6b72cf8287997252e8fab9cc6f52059ea966d915449a9bd4c64a5bf045e0725d62ff14baf6864cd5212c1765cb5738 SHA512 3a490b46094e92d66e7e0f8e2d0282b75cb33ee2a7a21e4f89029b0a454909466ff5ab4732193480203da9d2481c6134494ccef95953906f6a9da66cc9834830
+MISC metadata.xml 557 BLAKE2B 17a7d57f6d3a8d0a01808be1f9d5381ea21cec37bbaf193f6f5b28b3f8381fbdf5a00b06cefd89a777ca11f11556ed33b13e295aa5687d4eac76df537dc6fa41 SHA512 6325997c6f1fca6d8bd2fb3987ca8a53ee068847e4d184b36928a7265ff0aca1918dfbea34a8cd93f6d3b68aace8e28133d261766524f7da3639a307ace0e160
diff --git a/dev-python/dulwich/dulwich-0.20.15.ebuild b/dev-python/dulwich/dulwich-0.20.15.ebuild
new file mode 100644
index 000000000000..94bee1e29130
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.20.15.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend # tests use setuptools, setup uses if found
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="
+ https://github.com/dulwich/dulwich/
+ https://pypi.org/project/dulwich/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ !hppa? ( !ia64? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/geventhttpclient[${PYTHON_USEDEP}]
+ ) )
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-fastimport[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ # remove interference from the tests that do stuff like user.name
+ unset GIT_AUTHOR_NAME GIT_AUTHOR_EMAIL GIT_AUTHOR_DATE \
+ GIT_COMMITTER_NAME GIT_COMMITTER_EMAIL GIT_COMMITTER_DATE EMAIL
+ # Do not use make check which rebuilds the extension and uses -Werror,
+ # causing unexpected failures.
+ "${EPYTHON}" -m unittest -v dulwich.tests.test_suite \
+ || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/dulwich/metadata.xml b/dev-python/dulwich/metadata.xml
index 3b63ee79f5a8..c0e39697632d 100644
--- a/dev-python/dulwich/metadata.xml
+++ b/dev-python/dulwich/metadata.xml
@@ -5,9 +5,13 @@
<email>grobian@gentoo.org</email>
<name>Fabian Groffen</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<upstream>
<remote-id type="pypi">dulwich</remote-id>
- <remote-id type="github">jelmer/dulwich</remote-id>
- <bugs-to>https://github.com/jelmer/dulwich/issues</bugs-to>
+ <remote-id type="github">dulwich/dulwich</remote-id>
+ <bugs-to>https://github.com/dulwich/dulwich/issues</bugs-to>
</upstream>
</pkgmetadata>