summaryrefslogtreecommitdiff
path: root/dev-python/dulwich
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-06 11:01:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-06 11:01:58 +0000
commit334d7d1830a3556a4c5d62a0f8547e5eb40bc83e (patch)
tree21b32eab75d2e75a1706e24db41ef23a89bb0ca2 /dev-python/dulwich
parentb8cec1611ea575eea46e4927fedf000feed71b16 (diff)
gentoo auto-resync : 06:12:2023 - 11:01:57
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/Manifest2
-rw-r--r--dev-python/dulwich/dulwich-0.21.7.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index b738c6afd9cf..2cd71e928dda 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1,3 +1,5 @@
DIST dulwich-0.21.6.tar.gz 445545 BLAKE2B a3189b4777e295bf26345172fa1c4f6ca4c45e807a9197cd2bc8c0255a9ebb7fa752bc98369ffe780671dc9610fefb1fc4bd9b6b75d90b7322d048197da0aeaa SHA512 24f1d82be08b6ee78e41cd86ec2323a51dd6bff3714b1eae1f8484eda316c9d1c8089ded853511d587898ba789d36ee014c8f3b7c718bf7168519725f4d9dc2c
+DIST dulwich-0.21.7.tar.gz 448028 BLAKE2B 8ceace901ce4b444d6f40f7071b7a95a04d27a63b9076fd82c97b7fb551dd769c38940d0ec42ebfd6592154df912139f0ca58801ba2fa0ef412d6a749253500a SHA512 56ddf8db21088b264623c568f28caa80d8687d26e5127093daaa4d556b0f49218ac51491a47ced00e9af073bd7ca05b2eb8b29d64aae8b93dd4bd47ca67ee443
EBUILD dulwich-0.21.6-r1.ebuild 1400 BLAKE2B 865c569df71b2a3df33b3e4d5e32411730d635d7293ec2430a1b4ff9b7a4f2f14e323f19f23204226403d60b8b2d3e5d099be56142231a4190c8eae754705399 SHA512 3d4f0b94b12232eb35472cce12c32adfbf5bbe9f0ca3b02e5da6678a282e2234f92608da94acb731141633897c9c146ebeefeddf19a2857acc1a645e6ec45982
+EBUILD dulwich-0.21.7.ebuild 1404 BLAKE2B dd0a82d5efdf5c822573a51f9123ba861f8ae512cb9adc28d6007d1990c65099ade7ead4dbf666aa11e30de926bf765bc60777443cd3d4235b63cbdf2b2b43bc SHA512 1ee507e29393fa9ce6ceeccc9bf817547e76c61f389bd390eda12ffb902725d1b704cb0304d1988e3393bc67b0ce1370e01590a8b56ebe06fd975f5481540bb5
MISC metadata.xml 556 BLAKE2B 240554ff522160e9508bf6debadafcc44b5ccc4074dd4c9d3ce82358963084c60a1afae9fafee6ab1e6e5d898940ccb4d1b524cebff155e61bf6707c9396b647 SHA512 a7cdca224a01d5bd26bf4a5adb0273977ddff61f75cd02f5642132656fd0c6608114617efcb068d834f107804666cf4fb3725967e804b73d2ddcb67342dc30de
diff --git a/dev-python/dulwich/dulwich-0.21.7.ebuild b/dev-python/dulwich/dulwich-0.21.7.ebuild
new file mode 100644
index 000000000000..994b7cf3899b
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.21.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="
+ https://github.com/jelmer/dulwich/
+ https://pypi.org/project/dulwich/
+"
+
+LICENSE="GPL-2+ Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/urllib3-1.25[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ app-crypt/gpgme[python,${PYTHON_USEDEP}]
+ dev-python/fastimport[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ # remove interference from the tests that do stuff like user.name
+ unset GIT_AUTHOR_NAME GIT_AUTHOR_EMAIL GIT_AUTHOR_DATE
+ unset GIT_COMMITTER_NAME GIT_COMMITTER_EMAIL GIT_COMMITTER_DATE
+ unset EMAIL
+ # Do not use make check which rebuilds the extension and uses -Werror,
+ # causing unexpected failures.
+ "${EPYTHON}" -m unittest -v dulwich.tests.test_suite ||
+ die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}