summaryrefslogtreecommitdiff
path: root/dev-python/dominate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /dev-python/dominate
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'dev-python/dominate')
-rw-r--r--dev-python/dominate/Manifest3
-rw-r--r--dev-python/dominate/dominate-2.9.1.ebuild8
-rw-r--r--dev-python/dominate/files/dominate-2.9.1-py313.patch37
3 files changed, 45 insertions, 3 deletions
diff --git a/dev-python/dominate/Manifest b/dev-python/dominate/Manifest
index 8699ca2be8ce..075bae6a1b10 100644
--- a/dev-python/dominate/Manifest
+++ b/dev-python/dominate/Manifest
@@ -1,3 +1,4 @@
+AUX dominate-2.9.1-py313.patch 1059 BLAKE2B e56a68a364d07bf3aed0bc1fad58d74ed7bbf25cbf212ec8196d7efac8193b0a25b5ac3630725b6fb59461f1f72450c1496aa3ee86b791795762cc108463004a SHA512 233530f471a00b637a0d866bd415994f88d5e5a90d76bf780f4da48995d96527e9255fce9daf91eb44d6da1e7f0d6ece67e1cfb5f649e635d83f9fc14c451476
DIST dominate-2.9.1.tar.gz 37715 BLAKE2B df0271537916e57d50b0d1918f34cdbcd2b1f2bde1e50995593b242e75758f184515dd33518fec0c57c959f5a504dfebf4210814213b159bed2546af7369d915 SHA512 690f7228957cfc3c673bb1863f4e7d15c5e717c4bde24eb8280efc1be07cd50fae514a10b3208ee1b37e4d19d513622c7768b9efb61f11c286430832e873e8e5
-EBUILD dominate-2.9.1.ebuild 529 BLAKE2B de6798e0ccbf1c3b5ece232d21f15365fcf0fe525bad755f9cbd50d7046a21b1a7f849300d2108f13ebf5a641394705106439a730e8d96b8d7d0023d96c72d7a SHA512 ec4d5dc4b9695e8b65d40424768ed01c389ba075ec4b8a104863875782bb382fae92410672ef226565b26aab54fc231c8c59a35aa5dcdec9a06769251d19d144
+EBUILD dominate-2.9.1.ebuild 565 BLAKE2B 89f4ce25a6c21bee8596c87fcaa1c0535cd003f85910e6ae308f3d18a530809c9bf3dee995f44781d44f9090ca3c7286f7991b8b2772efa06e1d02792cd53d9a SHA512 3f93edd6e7e98d90126875088bc02d374466da7023689142ba8fa6285d8e6cfdb78427de713975691cd99f35ff871a401bf4a0a2dc9b153ab4fcc96bf1762a55
MISC metadata.xml 796 BLAKE2B a6b8a73d12e14552aed0f4b4f2a4b5ff282829d44da6a3e283a04575bc31069d5e83a0f475d184896c586b416882507fa22ccfb346aec90692a47f28ea54646c SHA512 9a018dd4858f7a89ac7cfd8b1814df9bb24ebe9e811f0f98e2fe52f047b14bf742648de9c0e4ce55ff69434755d8b365297bd41a5909c63697eed925e1a30b03
diff --git a/dev-python/dominate/dominate-2.9.1.ebuild b/dev-python/dominate/dominate-2.9.1.ebuild
index 85015fef18a1..22722a0e814f 100644
--- a/dev-python/dominate/dominate-2.9.1.ebuild
+++ b/dev-python/dominate/dominate-2.9.1.ebuild
@@ -4,8 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-# py3.13: https://github.com/Knio/dominate/issues/199
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit distutils-r1 pypi
@@ -20,3 +19,8 @@ SLOT="0"
KEYWORDS="amd64 arm64 x86"
distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/Knio/dominate/pull/202
+ "${FILESDIR}/${P}-py313.patch"
+)
diff --git a/dev-python/dominate/files/dominate-2.9.1-py313.patch b/dev-python/dominate/files/dominate-2.9.1-py313.patch
new file mode 100644
index 000000000000..944ad8596336
--- /dev/null
+++ b/dev-python/dominate/files/dominate-2.9.1-py313.patch
@@ -0,0 +1,37 @@
+From 58f7d7fdb171f80ed6ce97e6ca4409723975c47f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 3 Aug 2024 16:07:38 +0200
+Subject: [PATCH] Update tests for docstring dedenting in Python 3.13
+
+Update the `get_expected()` function to account for the fact that
+Python 3.13 automatically dedents all the docstrings, and therefore
+does not require explicitly removing the indent (which effectively
+removes too much indent).
+
+Fixes #199
+---
+ tests/test_svg.py | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/tests/test_svg.py b/tests/test_svg.py
+index e5bbec3..ea7d98f 100644
+--- a/tests/test_svg.py
++++ b/tests/test_svg.py
+@@ -1,3 +1,5 @@
++import sys
++
+ import dominate.svg
+ from dominate.tags import *
+ from dominate.svg import *
+@@ -14,7 +16,10 @@ def base():
+
+
+ def get_expected(func):
+- return func.__doc__.replace('\n ', '\n').strip()
++ doc = func.__doc__
++ if sys.version_info < (3, 13):
++ doc = doc.replace('\n ', '\n')
++ return doc.strip()
+
+
+ def output_test(func):