summaryrefslogtreecommitdiff
path: root/dev-python/dominate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
commit957235cf19a691360c720f7913672adda4258ed0 (patch)
tree812bba7928f4293ead05a7ee9c1ac39c5ef9f12e /dev-python/dominate
parent62f67115b5c46134c34f88f4b1cbdacc19384c0a (diff)
gentoo resync : 07.10.2018
Diffstat (limited to 'dev-python/dominate')
-rw-r--r--dev-python/dominate/Manifest4
-rw-r--r--dev-python/dominate/dominate-2.3.4.ebuild (renamed from dev-python/dominate/dominate-2.2.1.ebuild)19
2 files changed, 9 insertions, 14 deletions
diff --git a/dev-python/dominate/Manifest b/dev-python/dominate/Manifest
index 3b7882c36884..69a887d84ec1 100644
--- a/dev-python/dominate/Manifest
+++ b/dev-python/dominate/Manifest
@@ -1,5 +1,5 @@
-DIST dominate-2.2.1.zip 46460 BLAKE2B b09984978755f9020e78873aec73c09ccdf0113b99f1a0c9dcf43307a5523000f04ef2e063d03e636e2e958aa5dbd69993a8c606838cceb216599b314ab24a2e SHA512 3f79fa4258f98708b1e169693e83f919179c1148f440300426f907e28c26b28c21a1098793a14f7e89e5aba0de61f93c889a4908f0eb6e3641ffe234e215e597
DIST dominate-2.3.1.tar.gz 27887 BLAKE2B 3ac0820bd0cb79e648dc947d3cb69aa207e3c129cbae05daaca8fd3a6e22c67bd20fa350ce211986451caa7feb5b60c8ff692e568073e007c34de7cb8847b8a1 SHA512 599147cd9aabc7c3bc24e6c82a13b690808899107999a3b0d7d3f2f113b38c90f2c720298ffdcdf1933d2573cced05d730dab53265397b7fc010e57feabc10b3
-EBUILD dominate-2.2.1.ebuild 662 BLAKE2B 664c240b48ecddf85d01f1142b12bf5331d7073425bb7108f783379a02203ebc7a1ca5b1013dbd6f05238e6e267c3facc408695c0f7c426c9fa52c86e4846d94 SHA512 e35a3f04d9673cc915f2776e828c12be6654fd552537f7ed64f02106fdefada4836a3c12ce35b6227786c614ddb62b4b907e13778e34b0e347e9120ac48897dc
+DIST dominate-2.3.4.tar.gz 27834 BLAKE2B 12eadd39e5088768c2cfc15e23093c53c58d90dab6346ac78d47da8b7d41fb50fabf4e186b9fea18ecb54fe8b6dae03a489b27a1942cfdc13437afe9e86919ef SHA512 6cab8d6d795498d70f28c80064407616e74e027ac112f8e097509482dce000e45c3599989430a17f71631616a860e84d842b2bfac39b4be466593b5cfb20123c
EBUILD dominate-2.3.1.ebuild 606 BLAKE2B e59982d021a5797c993d4ea58bd57c831aca4a9c17901198af5c6477221f06dfe000b69f14f6367380ef95a91ea107318119bc91b122902119e18b904d2a29df SHA512 0319d71125e32159f0672c1c167e4c53f03f2076fab285b68e62a24b78bb93bf2f03e5e3efb8b4f6f65749882508e92cfd22aaddba8032ff953e6e767b1560e4
+EBUILD dominate-2.3.4.ebuild 605 BLAKE2B 48e0b5a55457b2ca26ca15cd356ecd60416abd72bc80f2782699783f2c5e10ed282e13937846a11167259a5320969afa4cb258a3931068a6f7b7d9a678c6652a SHA512 2b8a0b551234934af21f3e312c476c4a50049bbc34c054188140625bd32c440fba48cdb9f3bb012de41dfab001b36fedc01e655356332ed34da0d6bd9a6f7e7d
MISC metadata.xml 771 BLAKE2B b57440fdd8bad6140d982af019944cc740ba47183908dc2505c1436448e735cd63f537b3ef2158b6014c4dc050128b13881b368ef9ed5e840b37f7e88ac72a25 SHA512 2af8875459291f59c07ece49ac0edeab74408f54031878c1b03581bdbcfcb509caf37ee30d03e2f86f59dd67aba62c54808ca5a6c67037717113c3bfb6f9961e
diff --git a/dev-python/dominate/dominate-2.2.1.ebuild b/dev-python/dominate/dominate-2.3.4.ebuild
index 12751f810ead..078ac80b939c 100644
--- a/dev-python/dominate/dominate-2.2.1.ebuild
+++ b/dev-python/dominate/dominate-2.3.4.ebuild
@@ -1,30 +1,25 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
inherit distutils-r1
DESCRIPTION="Library for creating and manipulating HTML documents using an elegant DOM API"
HOMEPAGE="https://github.com/Knio/dominate"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
IUSE="test"
DEPEND="
- app-arch/unzip
dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
-RDEPEND=""
python_test() {
- py.test || die "Tests failed with ${EPYTHON}"
+ pytest -vv || die "Tests failed with ${EPYTHON}"
}