summaryrefslogtreecommitdiff
path: root/dev-python/dominate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/dominate
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/dominate')
-rw-r--r--dev-python/dominate/Manifest5
-rw-r--r--dev-python/dominate/dominate-2.2.1.ebuild30
-rw-r--r--dev-python/dominate/dominate-2.3.1.ebuild25
-rw-r--r--dev-python/dominate/metadata.xml16
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/dominate/Manifest b/dev-python/dominate/Manifest
new file mode 100644
index 000000000000..30575853d227
--- /dev/null
+++ b/dev-python/dominate/Manifest
@@ -0,0 +1,5 @@
+DIST dominate-2.2.1.zip 46460 BLAKE2B b09984978755f9020e78873aec73c09ccdf0113b99f1a0c9dcf43307a5523000f04ef2e063d03e636e2e958aa5dbd69993a8c606838cceb216599b314ab24a2e SHA512 3f79fa4258f98708b1e169693e83f919179c1148f440300426f907e28c26b28c21a1098793a14f7e89e5aba0de61f93c889a4908f0eb6e3641ffe234e215e597
+DIST dominate-2.3.1.tar.gz 27887 BLAKE2B 3ac0820bd0cb79e648dc947d3cb69aa207e3c129cbae05daaca8fd3a6e22c67bd20fa350ce211986451caa7feb5b60c8ff692e568073e007c34de7cb8847b8a1 SHA512 599147cd9aabc7c3bc24e6c82a13b690808899107999a3b0d7d3f2f113b38c90f2c720298ffdcdf1933d2573cced05d730dab53265397b7fc010e57feabc10b3
+EBUILD dominate-2.2.1.ebuild 662 BLAKE2B 664c240b48ecddf85d01f1142b12bf5331d7073425bb7108f783379a02203ebc7a1ca5b1013dbd6f05238e6e267c3facc408695c0f7c426c9fa52c86e4846d94 SHA512 e35a3f04d9673cc915f2776e828c12be6654fd552537f7ed64f02106fdefada4836a3c12ce35b6227786c614ddb62b4b907e13778e34b0e347e9120ac48897dc
+EBUILD dominate-2.3.1.ebuild 601 BLAKE2B db431a40a300b625bc9b4ddcb6b02fb6d5b537f3acd60c98668210069e57605db0785647bf4a80f36327f700d9f24be8d17e2bfab8d895fc77823d8fe4d7cb16 SHA512 10ecbbab20fd33e0a9e8b87e5e480715b81431e389ca913b77d8bbafa80b19ddb712360ba561b496092ba2d99e4ff097ab49d98fa2d962922afa2928c3a6be71
+MISC metadata.xml 771 BLAKE2B b57440fdd8bad6140d982af019944cc740ba47183908dc2505c1436448e735cd63f537b3ef2158b6014c4dc050128b13881b368ef9ed5e840b37f7e88ac72a25 SHA512 2af8875459291f59c07ece49ac0edeab74408f54031878c1b03581bdbcfcb509caf37ee30d03e2f86f59dd67aba62c54808ca5a6c67037717113c3bfb6f9961e
diff --git a/dev-python/dominate/dominate-2.2.1.ebuild b/dev-python/dominate/dominate-2.2.1.ebuild
new file mode 100644
index 000000000000..12751f810ead
--- /dev/null
+++ b/dev-python/dominate/dominate-2.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for creating and manipulating HTML documents using an elegant DOM API"
+HOMEPAGE="https://github.com/Knio/dominate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+python_test() {
+ py.test || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/dominate/dominate-2.3.1.ebuild b/dev-python/dominate/dominate-2.3.1.ebuild
new file mode 100644
index 000000000000..3844d909e582
--- /dev/null
+++ b/dev-python/dominate/dominate-2.3.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for creating and manipulating HTML documents using an elegant DOM API"
+HOMEPAGE="https://github.com/Knio/dominate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/dominate/metadata.xml b/dev-python/dominate/metadata.xml
new file mode 100644
index 000000000000..3df54468a06f
--- /dev/null
+++ b/dev-python/dominate/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sbraz@gentoo.org</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">dominate</remote-id>
+ <remote-id type="github">Knio/dominate</remote-id>
+ <bugs-to>https://github.com/Knio/dominate/issues</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ Dominate is a Python library for creating and manipulating HTML documents using an elegant DOM API. It allows you to write HTML pages in pure Python very concisely, which eliminate the need to learn another template language, and to take advantage of the more powerful features of Python.
+ </longdescription>
+</pkgmetadata>