summaryrefslogtreecommitdiff
path: root/dev-python/dominate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/dominate
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/dominate')
-rw-r--r--dev-python/dominate/Manifest6
-rw-r--r--dev-python/dominate/dominate-2.2.1.ebuild30
-rw-r--r--dev-python/dominate/dominate-2.3.1.ebuild28
-rw-r--r--dev-python/dominate/metadata.xml20
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/dominate/Manifest b/dev-python/dominate/Manifest
new file mode 100644
index 000000000000..161249042f58
--- /dev/null
+++ b/dev-python/dominate/Manifest
@@ -0,0 +1,6 @@
+DIST dominate-2.2.1.zip 46460 SHA256 4aa6a2f458461541f9ceeb58b49da9b42320f80aa2a6f692baea2817431d9953 SHA512 3f79fa4258f98708b1e169693e83f919179c1148f440300426f907e28c26b28c21a1098793a14f7e89e5aba0de61f93c889a4908f0eb6e3641ffe234e215e597 WHIRLPOOL 18b57dfc4d0f825be45a1b248e434a8a013d5b76f065b854c47aab9d99c00f5d1854fbcd3c520de50b11b5d7f079f6e57b2e7167249b7e71ff980ac02dfd8100
+DIST dominate-2.3.1.tar.gz 27887 SHA256 4b8ce6f33633c9dd9175b228d21c00c801b6bd0327747cd5e17fc2da934c3a69 SHA512 599147cd9aabc7c3bc24e6c82a13b690808899107999a3b0d7d3f2f113b38c90f2c720298ffdcdf1933d2573cced05d730dab53265397b7fc010e57feabc10b3 WHIRLPOOL 258b490620bf358829a74bb7586864a078004268e7bd140322d27126484824ccff0533a87f41948bb13ce19cd47b020d16181a4ea7d74c3f12bf18479b047939
+EBUILD dominate-2.2.1.ebuild 662 SHA256 e2036945dd802436b66055157de74374eca62602bde8732a4e7374941daf9897 SHA512 e35a3f04d9673cc915f2776e828c12be6654fd552537f7ed64f02106fdefada4836a3c12ce35b6227786c614ddb62b4b907e13778e34b0e347e9120ac48897dc WHIRLPOOL 41b56939df384b81882a08083892ec82895d533c7dbc3409a9430cb3548689e31e7c72928b8fbbd6158661de632e45f7d642f33d15893349200c99bc4d605c2e
+EBUILD dominate-2.3.1.ebuild 644 SHA256 6906942c65255403a7cbd6007c93fd3a7e9654435eceb80af345a4b22be29291 SHA512 b9b84c0d793f09f3535bb41ea8c1ba2eadeaaf21603d81283f7c20d1e232d96f45f8c5eb68206db5cf5a06475a72b88530ede477e716a54afb0f3637a16c56e3 WHIRLPOOL 3de612b96b06943247dba5a2d0ddf0a66d65d3b79d23aa1f66210fa0651ae31b9cb724f4899645fe0864f678a97bd280181993b666a93d520fde69d70ee2f338
+MISC ChangeLog 1445 SHA256 f18e651a469f457b794eb062f682b415a7a1789fabd131dce200d60bdf744a62 SHA512 6145560ee09a4e372f0a32e412c71c9dec4279baf3670bee5281bd098790b8c622b510f2a9d1c654db717b01c77572d70d6a290bab6cecf84de4cbc283515d98 WHIRLPOOL 6b9c9b53b183d4e79a6249917a3cebeb13999fb4a212807ba725ed029f0af7ea4668f63005c0fb6b00b0b2f0aab0703cfc45a5ab30994e76d855bb46ec3121c4
+MISC metadata.xml 895 SHA256 3a1d014a7235e7cf1e25a4d543159734c1f02280892214d80039ff99ca060fab SHA512 97da1b81046a4ca19ff4cd66eaae0b0f49dc04e9d1368498e03ee577222f6a754eb467500ac1f47e26f6098aaaafaaa805da5d72b14202a48288c31391420738 WHIRLPOOL 6f89da042c99d5a3c64f6a752d39115b08e1f5e4f0ee9d4392b57f2e979fd93140904b14de6df757277b7d6de79efb1b71483de1aafcd586a0e183f54bea568a
diff --git a/dev-python/dominate/dominate-2.2.1.ebuild b/dev-python/dominate/dominate-2.2.1.ebuild
new file mode 100644
index 000000000000..12751f810ead
--- /dev/null
+++ b/dev-python/dominate/dominate-2.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for creating and manipulating HTML documents using an elegant DOM API"
+HOMEPAGE="https://github.com/Knio/dominate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+python_test() {
+ py.test || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/dominate/dominate-2.3.1.ebuild b/dev-python/dominate/dominate-2.3.1.ebuild
new file mode 100644
index 000000000000..d149b940eab5
--- /dev/null
+++ b/dev-python/dominate/dominate-2.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for creating and manipulating HTML documents using an elegant DOM API"
+HOMEPAGE="https://github.com/Knio/dominate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/dominate/metadata.xml b/dev-python/dominate/metadata.xml
new file mode 100644
index 000000000000..3f517fafb3d4
--- /dev/null
+++ b/dev-python/dominate/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">dominate</remote-id>
+ <remote-id type="github">Knio/dominate</remote-id>
+ <bugs-to>https://github.com/Knio/dominate/issues</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ Dominate is a Python library for creating and manipulating HTML documents using an elegant DOM API. It allows you to write HTML pages in pure Python very concisely, which eliminate the need to learn another template language, and to take advantage of the more powerful features of Python.
+ </longdescription>
+</pkgmetadata>