summaryrefslogtreecommitdiff
path: root/dev-python/doit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/doit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/doit')
-rw-r--r--dev-python/doit/Manifest5
-rw-r--r--dev-python/doit/doit-0.23.0-r1.ebuild62
-rw-r--r--dev-python/doit/doit-0.29.0.ebuild70
-rw-r--r--dev-python/doit/metadata.xml8
4 files changed, 145 insertions, 0 deletions
diff --git a/dev-python/doit/Manifest b/dev-python/doit/Manifest
new file mode 100644
index 000000000000..24d0e6512ea6
--- /dev/null
+++ b/dev-python/doit/Manifest
@@ -0,0 +1,5 @@
+DIST doit-0.23.0.tar.gz 316588 BLAKE2B c7c2edc3e38e60bf4cdf6bd7eae4f65606da3168e3def4710ef0a2e07fe9c9c70b5555bfc1b2858f3536ba2ff3a9b8624353d1bf8b1ed8901f76a2cd5f32ae9b SHA512 f2298d76d9ce3e7ed5f356bfdeeef8d5d99ebae74571666a3d2b3843fc63f5a8f76cd6cdedcfe8fc81bc653ecf04951c11f50abd16e9aa8fc7539e3c224b0e4c
+DIST doit-0.29.0.tar.gz 222341 BLAKE2B 8489568fe9236af04f87debfb4889840aa162d17d20f82ac0a9a22d1034b4c58976cd6829486a15b941ac1f50e7137c052fe332657c2b3f529fe2345bbcba2fc SHA512 a686457df31b414d0c3797789e0ae1ae5cdfa3674025236419cb59b254f342cd2db07911ef18b2cb576d8d817b44035b9372265b34b786b2779fb7074b394de1
+EBUILD doit-0.23.0-r1.ebuild 1940 BLAKE2B 6f60ee7f2ce6954b23bada22deb6e5cdd92284fa2d0e2d24167587121d14ba972f8266a20f797dfe1915b2e1b621366e1b5b9bf204788daa2f47e4544053ad0f SHA512 a026f37be0d3d598e338c1e0d45f9a8c9960e49f57660c8e913c73d94354204fefbd288e0adf17573c04c30130d5750fc375bff86a9ab2bb69d178859861125c
+EBUILD doit-0.29.0.ebuild 1966 BLAKE2B 514ccfde7fcd71bb9dc5ece1c9e18349661b13da76efc4f9e12e9ff1a7333076352aec1cfde5506a157ee82714713f7c6a3441311d190d78638a299dc8358e6e SHA512 500232ce6270d4c4a614a571c3aea7e4985146b2dd476446a4b378c4bc5a75a7bd41724142ed0e17a458cda16eff31d36ac9aa54a276a529d4440f28e5931baa
+MISC metadata.xml 268 BLAKE2B 8c954a752c6b0d24a4622e78c29524fa808dda953da46229a5d1e757ae6fb88f796e0f8473e30a9748b07ab9464186bbd988f12dd96c3d2f19e176419eaf3ecb SHA512 7318c022300ab1ccfddb09bbf4789f64185dba13c3e4befa77f0e7aaaea4fa650508f66cf39d00c760ceea31872022d40523af05ecaac1c6b59005bc23f5bc42
diff --git a/dev-python/doit/doit-0.23.0-r1.ebuild b/dev-python/doit/doit-0.23.0-r1.ebuild
new file mode 100644
index 000000000000..be6079f28e09
--- /dev/null
+++ b/dev-python/doit/doit-0.23.0-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} pypy )
+inherit eutils distutils-r1
+
+DESCRIPTION="Automation tool"
+HOMEPAGE="http://python-doit.sourceforge.net/ https://pypi.org/project/doit/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="test"
+
+RDEPEND="dev-python/pyinotify[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+# Required for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+DOCS=( AUTHORS CHANGES README TODO.txt dev_requirements.txt )
+
+python_prepare_all() {
+ use test && DISTUTILS_IN_SOURCE_BUILD=1
+ # Tests of this file fail due to setting of a tmp dir which can be fixed.
+ # This known spurious cause does not warrant halting a testsuite
+ rm -f tests/test_cmd_strace.py || die
+
+ # These 2 tests succeed on running the suite a second time, so they are NOT broken
+ # A gentoo test phase is run only once, so these unbroken tests can be safely skipped.
+ sed -e s':testInit:_&:' -e s':testLoop:_&:' \
+ -i tests/test_filewatch.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Testsuite is designed to be run by py.test, called by runtests.py
+ # https://bitbucket.org/schettino72/doit/issue/78/tests-that-fail-under-pypy
+ if [[ "${EPYTHON}" == pypy-c2.0 ]]; then
+ sed -e 's:test_corrupted_file:_&:' \
+ -e 's:test_corrupted_file_unrecognized_excep_pdep:_&:' \
+ -i tests/test_dependency.py || die
+ elif [[ "${EPYTHON}" == python2.6 ]]; then
+ rm -f tests/test___main__.py || die
+ sed -e 's:test_invalid_param_stdout:_&:' \
+ -i tests/test_action.py || die
+ sed -e 's:test_run_wait:_&:' \
+ -i tests/test_cmd_auto.py || die
+ fi
+ "${PYTHON}" runtests.py
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ dodoc -r doc
+ docompress -x /usr/share/doc/${PF}/doc
+}
diff --git a/dev-python/doit/doit-0.29.0.ebuild b/dev-python/doit/doit-0.29.0.ebuild
new file mode 100644
index 000000000000..c7fff2e71f7c
--- /dev/null
+++ b/dev-python/doit/doit-0.29.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+inherit eutils distutils-r1
+
+RESTRICT="test" # can't work as it imports nonexistant modules from coverage
+
+DESCRIPTION="Automation tool"
+HOMEPAGE="http://python-doit.sourceforge.net/ https://pypi.org/project/doit/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' python2_7 pypy)
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}] )
+"
+PDEPEND=">=dev-python/doit-py-0.3.0[${PYTHON_USEDEP}]"
+
+# Required for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Disable test failing due to impact on PATH run in a sandbox
+ sed -e s':test_target:_&:' -i tests/test_cmd_strace.py || die
+
+ # Test requires connection to an absent database
+ sed -e s':testIgnoreAll:_&:' -i tests/test_cmd_ignore.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ local -x TMPDIR="${T}"
+ # disable tests where pypy's treatment of some tests' use of a db is incompatible
+
+ if [[ "${EPYTHON}" == pypy ]]; then
+ sed -e 's:test_remove_all:_&:' -i tests/test_dependency.py || die
+ sed -e 's:testForgetAll:_&:' -i tests/test_cmd_forget.py || die
+ sed -e 's:test_not_picklable:_&:' \
+ -e 's:test_task_not_picklabe_multiprocess:_&:' \
+ -i tests/test_runner.py || die
+ fi
+
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_src_install
+}
diff --git a/dev-python/doit/metadata.xml b/dev-python/doit/metadata.xml
new file mode 100644
index 000000000000..aa35e52686ed
--- /dev/null
+++ b/dev-python/doit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">doit</remote-id>
+ <remote-id type="sourceforge">python-doit</remote-id>
+ </upstream>
+</pkgmetadata>